It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I simply cannot get my joystick to work with this game. I've not had a problem getting it to work with any other game (even other good old ones) but IW2 simply doesn't seem to want to work.

The joystick in question is a Saitek Cyborg X, and the OS is Windows 7 64bit.

Drivers seem to work fine, and as I say the stick works fine with every other game. I have noticed it seems to exist as two devices (Saitek Cyborg X & Virtual Hid Device).

I've tried making both the primary for older programs using
Control Panel -> Devices and Printers -> Cyborg X -> Advanced
but to no avail.

Any help offered would be appreciated. Thanks.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Does this help? [url=][/url]
7upMan: Does this help? [url=][/url]
I'm afraid not. I already tried unplugging and uninstalling all other game controllers and setting both Saitek devices as primary. Nothing works.
Sorry, can't help you there. My Thrustmaster Flightstick X works perfectly fine.