It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have trouble starting the game on my Vista x64 setup. So far I've reinstalled, attempted compatibility mode, admin, running all three of the possible .exe files that can start it, shortcut etc
All I get is this black screen (see attachment.)
I checked the flux.txt log, and it seems to fail on this particular line:
"FLUX: [unknown] LINKER: The package "ifrontendgui" is dependent on package "igame", which failed to load or link"
This question / problem has been solved by Ravengerimage
So am I correct in deducing I-War 2 (from GOG) will not work in Win7 x64 (which I have)? Or is it only some people having problems? I notice the game card does not mention Win7 at all. This is unfortunate. I wanted to buy it, and it happens to be on special for half price right now.
I had the same problem (Win7 x64) and none of the proposed solutions worked. However, when I saw a in the main folder and randomly unzipped it, overwriting all preexisting files in the resources folder (the files had different sizes, so something changed) the game started working just fine. Now let's hope there won't be any strange bugs because of my meddling. It's rather baffling, really.

A wizard did it.
Hey, Menus - you found a totally new solution! That makes it sound like the game could be packaged wrong, or having trouble accessing the zip format. Hopefully someone at GOG is reading so they can track down this wizard and interrogate him. ;)
Possibly it's because WIndows 7 has native zip file handling, which could maybe cause a conflict with the game's built-in zip file handling.

Unzipping the is a good work-around in that case. That said, I've not had any problems running the original version on my Windows 7 PC with the left as it is.
DEP fixed it for me.
Tried all the fixes in this thread but am still getting the following message:

FLUX: [unknown] LINKER: The package "ifrontendgui" is dependent on package "igame", which failed to load or link

Looks like it is looking for igame.pkg in the resources/package folder

---- ENVY 15; ATI Mobility HD 4830; Win7Ultimate x64

SOLVED: In addition to all the fixes in this thread, I had to create a shortcut to "C:\Program Files (x86)\\Independence War 2 - Edge of Chaos\EdgeOfChaos.exe" and use that instead of the default shortcut to "loader.exe". Note... Just creating the alternate shortcut did not work for me. I had to implement all the fixes in this thread as well.
Post edited June 11, 2012 by jibc