It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Heh, all I did for that update was copy the files from this version into my Workshop folder and hit "update". The Workshop version has become randomly corrupted in the past, so I was hoping that was what happened again.

So, it's still the same version.
avatar
visserzer0: Heh, all I did for that update was copy the files from this version into my Workshop folder and hit "update". The Workshop version has become randomly corrupted in the past, so I was hoping that was what happened again.

So, it's still the same version.
Ok thank you!
Can you send the Tellurian Campaign mod over? Either of them will work. Please and thank you!
I didn't find the follwing question answered in the FAQ, so ...

I would like to translate the mod to German. I currently don't know how to do this or if you use any tools for that, but I am willing to translate everything so that german players don't have that language mix they currently have.

I am looking forward to hearing from you soon!
Is there a workaround for the language bug in 2.4.1?
avatar
wackypanda: Is there a workaround for the language bug in 2.4.1?
Actually there is a solution: https://steamcommunity.com/app/324680/discussions/0/1694920442944041066/

(Just replace "Steam" with "GOG Galaxy" in step 5 if you are using the client.)
We've finally released version 2.5 after more than a whole year. Phew! Check out the patch and read the changelog on our ModDB page: https://www.moddb.com/mods/tellurian
avatar
visserzer0: We've finally released version 2.5 after more than a whole year. Phew! Check out the patch and read the changelog on our ModDB page: https://www.moddb.com/mods/tellurian
Thank you very much !