It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I was having the lag problem on W7, after having installed the widescreen mod the tweaks. Some combination of the ie-ddraw-fix-iwd.cmd file and checking "Disable Desktop composition" under compatibility got the lag to go away it seems.
this is the IWD 2 GOG version? the normal one , not the enhanced?

i just installed the icwd 2 version collectors edition from retail dvd ( i also have both GOG games)
just bought this collectors edition seevral days ago, and the icewind dale + heart of winter, the dvd case reads: the original Icewind Dale & Heart of Winter , i bought it at 7 and 12 euros, cause i was hoping that it would have a small paper manual like, yuris revenge had, theres plenty space in the small dvd case, but those retail dudes
cheaped out on the manual so now i also have the old stuff (it works) but i bought it for the manual :D

Anyways , i will have to install the iwd again ( uninstalled because my hd had insufficient free space (had to clean it up)

had to login again(after closing browser it seems your logged out(i guess for security and you have to login (my game accounts also logout when i close a tab),
brower hung because IWD2 was hogging CPU even in windowed mode it uses 25% of all 4 cores
thats quite a lot , games does not like alt tabbinb even in windowed mode, when in full screen it will cause loads of lag

as i am typing iwd2 is soaking up 30% of CPU (window mode)
GPU is at 48 degrees celsius so thats okay
cores are at 66 , 55, 52, 52, degrees celsius
Over the years i have noticed that programs and games (also newly released retail games)
are (ab)using lots of gpu and cpu power, normally you would think that as technology advances, things would be better, but it gets worse.

So its quit laggy right now :D
Post edited May 15, 2015 by gamesfreak64
I gave up trying to get the gog versions of IWD, IWDII to work, they installed, and ran(eventually after much tweaking), but very poorly. I ended up dusting off my old CD box sets, they work fine on Win7,Win8, and Win10, straight out of the box, or at least they did for me, on all 3 of my pc's I installed them on.
I got the gog version simply due to it being in an rpg bundle, but neither of those work without some serious messing around and tweaking, and then they perform really poorly.
I just wanted to say that you shouldn't force ddraw emulation as the game runs buggy/laggy. Run the setup-ddrawfix.exe again and change it back to Wined3d.

Now, launching the game will take over a minute. Just be patient. Don't alt-tab, or anything or you'll get "not responding" errors. Just wait and count to 90, it should launch by then and play perfectly.
Does Forcing DirectDraw Emulation install a program in the windows program manager?
The link to the tweak pack is dead. i'm searching for an alternate download location but haven't found one yet. Anyone else have one? if I find one, I'll post it.



Just found this:

Not sure if it's the most recent version.

BTW, why is Gibberlings down?
Post edited July 03, 2016 by rignes
The mod is still up on G3? (gibberlings3 [dot] net)

bit late..but good for someone else klickin this
I found that using this DirectDraw wrapper works best on my Windows 10 laptop, I'll have to check for Windows 7 when I'm on my PC:

Just extract the ddraw.ddl into the Icewind Dale II installation folder. It works only in fullscreen mode for me, though.
I used the v0.21, not the experimental release.

edit: The IE DDrawFix ( works better on my PC. I haven't tried it on my laptop, yet.
Post edited June 10, 2019 by Pherim
For anyone having issues running IWD2, use cnc-ddraw on GitHub. It's a more modern alternative to DDrawCompat.
after installing widescreen patch and cnc-ddraw i have issue with mouse glitch like mouse leaves a trail of copies when you move it
tried various options with cnc, nothing works
any idea how it can be fixed?
ps can't upload screenshot and can't post links to show the glitch
Post edited January 05, 2022 by CursedCrypt
rjawiygvozd: Tool called ddwrapper helped, you only need to set NoVideoMemory to 1 in configuration file. You can find it in Google.

Current GOG version actually works fine with wine directdraw, but it has alt-tab problems and takes a long time to load. With this wrapper there seem to be no problems.
If anyone's still struggling with getting IwD2 to run fine on a Win10 system, this helped me.

What I've done was:
1. Installed the game from Gog.
2. Installed the Tweaks Anthology.
3. Installed the Widescreen mod (at this point the game would run fine but wouldn't alt-tab/minimise at all).
4. I downloaded ddwrapper and set NoVideoMemory to 1 in the config file, then moved both of these into the IwD2 installation folder.

The game seems to be running fine and I can alt-tab out of it, too :)
Just patiently wait for the fanmade IWD2:EE to come out of beta.

Amongst many,many fixes and improvements and changes (all optional!) a new type of fog of war is introduced, which does not flicker.