It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


I am using Windows 10 Pro and can play this game exacly once per install. This is what happens:

The game installs fine, I can do the setup and start the mission. I can save and load, no problems. Then when I end the game via the regular menu item, a message tells me the program has crashed. OK, I wanted to end the game anyways, so no sweat.

Then I want to play again; it loads and I get to the menu, but starting any mission leads to the same crash. In the application event log I get events 1000 and 1001, e.g.:


Faulting application name: igi2.exe, version:, time stamp: 0x3f7752d7
Faulting module name: nvd3dum.dll, version:, time stamp: 0x56716b48
Exception code: 0xc0000005
Fault offset: 0x0054c500
Faulting process ID: 0x1410
Faulting application start time: 0x01d14c9c7efcebc7
Faulting application path: D:\gog\IGI 2 - Covert Strike\igi2.exe
Faulting module path: C:\Windows\SYSTEM32\nvd3dum.dll
Report ID: fedcec26-2ad9-4835-b675-09ae238f6ee6
Faulting package full name:
Faulting package-relative application ID:


Fault bucket 107845446334, type 1
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: igi2.exe
P3: 3f7752d7
P4: nvd3dum.dll
P6: 56716b48
P7: c0000005
P8: 0054c500

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_igi2.exe_895186a3865dc59717151b89b3e08a7d19f3_7d66 ac7f_1d8ee8c9

Analysis symbol:
Rechecking for solution: 0
Report ID: fedcec26-2ad9-4835-b675-09ae238f6ee6
Report Status: 0
Hashed bucket: d55628ecce1645b37e666649b074827b


I have tried
* disabling DEP for igi2.exe
* all compat settings
* running as Admin
* updating graphics drivers

but can't get it to run. If I uninstall and reinstall, it works exacly once as described above and that's it. Judging from the event log, it has to do with the nVidia drivers, and as the 0xc0000005 exception happens only with this game, my memory is probably OK.

Any ideas?
Post edited January 11, 2016 by fpv
No posts in this topic were marked as the solution yet. If you can help, add your reply
I have a similar issue running Win 10 pro also. I can save and load the mission only at the beginning. If I try later on, the game tells me it's saved but hangs on a blue sky screen. I can still escape and go back to the opening menu and exit the game but, after I restart it, the saved games are gone and I have to start from the beginning. I did this four times before giving up. I will try running the game under Win 7. If this does not work then yet an other dud.
Did you get it to work? I have exactly the same problem.
Hi there, any chance somebody has a solution on this? I experience pretty much the same error. The game crashes upon loading the mission and gives an error about direct X.

actually the one reason to stick to for those games is that usually you have them working... I would really appreciate any feedback. Thanks.
Try set all options on ultra low and try run mission again.