It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


I downloaded and installed the linux .sh installer for hypnospace today. The game installs and starts up as normal, as far as I can tell from comparing to let's play videos of the game.

During gameplay, I will experience momentary hangs on occasion--a second or two where the cursor isn't moving, letters not registering as a type. Sometimes the music will get stuck on a single note that it holds (though sometimes the music just keeps playing). As I continue playing the game, these hangs get more frequent, and longer. 20-30 seconds, 40+, and eventually it just stops responding. This doesn't take long--maybe 10 minutes to get to an unplayable level.

When this happens, I am able to alt-tab out of it with no issue. I can turn the numlock light on and off on my keyboard, I can use keyboard shortcuts to change my volume, and when I alt-tab to the desktop I can move my mouse around--so it's not freezing up the whole system, just inside the game. Sometimes after a few minutes, the game will have a brief burst of activity--my attempts to close windows in HypnOS using the ESC key will have registered and the cursor will move again, allowing me to exit the game to save my progress, but if I'm not quick very soon it'll freeze up again.

I've gone into the hypnos bios and turned the cursor trail to 0 and turned on agressive music memory collection and they've seemed to do nothing to improve the situation.

The terminal output when I run is as follows:

>rob@rob-Desktop:~/Gaming/GOG/Hypnospace Outlaw$ ./
>Running Hypnospace Outlaw
>[12044:12044:1224/] --ignore-gpu-blacklist is deprecated and will be removed in 2020Q4, use --ignore-gpu-blocklist instead.
>[12044:12052:1224/] --ignore-gpu-blacklist is deprecated and will be removed in 2020Q4, use --ignore-gpu-blocklist instead.
>[12044:12052:1224/] Failed to open NaCl IRT file "/home/rob/Gaming/GOG/Hypnospace Outlaw/game/nacl_irt_x86_64.nexe": -4
>[12072:12080:1224/] No net_fetcher for performing AIA chasing.
>[12072:12085:1224/] No net_fetcher for performing AIA chasing.
>pre-main prep time: 0 ms
>[12072:12080:1224/] No net_fetcher for performing AIA chasing.
>[12072:12080:1224/] No net_fetcher for performing AIA chasing.
>[12072:12444:1224/] No net_fetcher for performing AIA chasing.
>[12072:12444:1224/] No net_fetcher for performing AIA chasing.

And that net_fetcher error just repeats until I stop the game. But as far as I could figure out that has something to do with remote SSL certificates and comes up in remote desktops. I assume that I'm not actually logging into a remote instance of HypnOS so I have no idea what this error has to do with the game.

I looked up the NaCL IRT error, and there's a thread about it on Steam where it seems to have something to do with NWJS versions, but another user reported downloading a version of it to put into the directory specified in the terminal output. It removed the error in the terminal output, but didn't fix their their issue (which was a black screen at launch, so not the same as my issue):

There's also a thread specificially about the game running slowly on linux: However, they just assume it was a deliberate gag in the game (as did I, at first) or a memory leak with no solution other than to restart.

Please help! I really want to play, but I don't want to do it 10 minutes at a time while fighting through frequent hangs.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Well shoot. Okay I'll have to do some research on this. In the meantime if you're up for an adventure, you can try to replace the NWJS engine files with the ones on the Construct 2 site or the NWJS site:

I believe we're currently using NWJS 0.49.0. If you do embark on this quest, note that the "HypnOS" file is just a renamed "nw" file, and you may have to CHMOD a+x the nw file. I'll put this on my list and will hopefully have time soon to try and fix this myself!

Email me if you have anything more to add, michaeltl88 [at] gmail [dot] com
Alrighty, I'll try replacing NWJS with one of the proper ones and let you know how it goes. Thanks for replying--I was beginning to give up hope!
Hi there Rob, just curious if you had a chance to mess around with other NWJS builds? I personally haven't seen these issues, and there are of course infinite permutations of PC configurations and Linux distros, so it's difficult for me to test if one build is any different than another. If you'd like to take this to email I can work with you directly on it: michaeltl88 [AT] gmail [DOT] com
Hello, Mike. I've tried the solution you suggested, but I appear to have done something potentally incorrect.
OK I put together some instructions on how we may be able to solve this issue. It does indeed appear to be an NWJS issue.

Change the "gpu-blacklist" argument to "blocklist":

1. Open the Hypnospace Outlaw install folder
2. Open package.nw (it's a zip file in disguise, you don't have to unzip it)
3. Edit the package.json file inside - you'll see "--ignore-gpu-blacklist", go ahead and replace it with "--ignore-gpu-blocklist"
4. Save the .json file, go back to the .nw file and if it asks you to update the file because it has been modified in an external application, go ahead and click "Update" and then close the .nw file

Update NWJS to a newer version:

1. Download a newer version of NWJS (currently Hypnospace uses 0.49.0), I recommend trying 0.52.0 or 0.51.2:
If you're trying 0.52.0, for example, you'd want to download this file "nwjs-v0.52.0-linux-x64.tar.gz"
2. Open the Hypnospace install folder. Delete everything EXCEPT FOR:
__a. package.nw
__b. the data folder
3. Open the NWJS file you downloaded
4. Copy over the following files/folders *note that some only exist in the SDK version, so copy over the files below that exist in the .tar.gz file you chose*
__a. swiftshader
__b. locales
__c. lib
__d. v8_context_snapshot.bin
__e. resources.pak
__f. nw_200_percent.pak
__g. nw_100_percent.pak
__h. nw
__i. nacl_helper_bootstrap
__j. nacl_helper
__k. icudtl.dat
5. Rename "nw" to "HypnOS"
6. In terminal, use the following command:
chmod a+x HypnOS
7. Try running ./HypnOS from terminal

Let me know if this helps!
Post edited March 19, 2021 by TetroniMike
Update! If you try the above, please try using NWJS 0.49.1, I have one person confirming it fixes the problem and does not cause additional issues (at least that they have noticed). Thank you for your patience.
Post edited April 09, 2021 by TetroniMike
I had similar symptoms to what RobMagus described, and TetroniMike's procedure resolved the issue. In the hopes of helping others, I have two notes to add:

1. These symptoms appear to have been caused by a bug in nw.js which was fixed in version 0.49.1. See for details.

2. I first attempted to upgrade nw.js to the latest version, but this introduced other issues. I will stick with version 0.49.1 for now.
Hey folks! I've officially updated the Linux builds to NWJS version 0.49.1. Please let me know if you continue to experience performance or other issues.