It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hello
I have bought HyperLightDrifter but I get this error:

./HyperLightDrifter.x86: error while loading shared libraries: libcurl.so.4: cannot open shared object file: No such file or directory

when I try to run it. (on Terminal because on X it doesn't show the message, it just doesn't work.

Big thanks to Caelistas for the help:

Hyper Light Drifter: Fix libcurl.so.4 on ubuntu
Post edited December 23, 2016 by MoonSong
Ok!

Thanks to a friend of mine:
if you run Linux 64 Bit use:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get -y install libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386

If it's already installed all you need is just:
sudo apt-get install libcurl3:i386

It'll install the libraries necessary for the game to run.
Post edited December 23, 2016 by MoonSong
avatar
MoonSong: Ok!

Thanks to a friend of mine:
if you run Linux 64 Bit use:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get -y install libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386

If it's already installed all you need is just:
sudo apt-get install libcurl3:i386

It'll install the libraries necessary for the game to run.
I only had to install sudo apt-get install libcurl3:i386, this is on Mint 18.1 64bit and that seems to have done the trick for me.
even better
Good to know
avatar
MoonSong: Ok!

Thanks to a friend of mine:
if you run Linux 64 Bit use:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get -y install libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386

If it's already installed all you need is just:
sudo apt-get install libcurl3:i386

It'll install the libraries necessary for the game to run.
avatar
icebrutality: I only had to install sudo apt-get install libcurl3:i386, this is on Mint 18.1 64bit and that seems to have done the trick for me.
Thanks a LOT. This actually worked for me on my Linux Mint 18.0 64 bit for 2 other games made with GameMaker (Bot Vice and Strikey Sisters).
DANKE

Game is Ready
Post edited June 10, 2018 by Jeffreys
Thanks
avatar
MoonSong: Ok!

Thanks to a friend of mine:
if you run Linux 64 Bit use:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get -y install libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386

If it's already installed all you need is just:
sudo apt-get install libcurl3:i386

It'll install the libraries necessary for the game to run.
I had to do much more installs :

sudo apt-get install libpsl5:i386 librtmp1:i386 libnghttp2-14:i386 libnghttp2:i386 libcurl3:i386 libssl1.0.0:i386 libcrypto:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386

But libcurl3 was conflicted with libcurl4 used by virtualbox, so had to decompress directly the package in place :

https://packages.ubuntu.com/bionic/i386/libcurl3/download