It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
Kalki10: I DLed emergence a few days ago and tried running it. Every time I hit the final splash screen in the intro it crashes to desktop. I tried using compatibility mode, making an exception in trendmicro, no luck. Can I get some help?
avatar
Cheezowhiz: Same Problem. I reached out for help. I was told to download some old direct x drivers, update my graphics card drivers and reinstall the game. I see that there is a 1.01 Hotfix but still that doesn't change anything. I messed with the nglide settings and the compatibility as well. It crashes right after the 3dfx logo no matter what changes I have made.
I had similar problem. Except it doesnt crash, but remained black screen instead of menu.
I solved it by deleting/renaming "opengl32.dll" in "Homeworld Emergence\3Dfx\WinNT"
And downloading the right "opengl32.dll" for your OS from here:
http://www.dlldownloader.com/opengl32-dll/
and placing it in its folder "Homeworld Emergence\3Dfx\WinNT"
Hope it helps
avatar
Cheezowhiz: Same Problem. I reached out for help. I was told to download some old direct x drivers, update my graphics card drivers and reinstall the game. I see that there is a 1.01 Hotfix but still that doesn't change anything. I messed with the nglide settings and the compatibility as well. It crashes right after the 3dfx logo no matter what changes I have made.
avatar
mmax2: I had similar problem. Except it doesnt crash, but remained black screen instead of menu.
I solved it by deleting/renaming "opengl32.dll" in "Homeworld Emergence\3Dfx\WinNT"
And downloading the right "opengl32.dll" for your OS from here:
http://www.dlldownloader.com/opengl32-dll/
and placing it in its folder "Homeworld Emergence\3Dfx\WinNT"
Hope it helps
This might have helped me, not too sure as first time I installed through Galaxy. Which did the small black box thing.

Subsequent attempts with the black corner box were with anti-virus real time on, the black screen with the sound working were after I switched it off.

I reinstalled sans galaxy too.

So I came to have a look around here for possible solutions. Now the first time it worked, I had my browser open. I just played through the first mission after many failed startups, I had the browser open again.

This game is weird.
avatar
Cheezowhiz: Same Problem. I reached out for help. I was told to download some old direct x drivers, update my graphics card drivers and reinstall the game. I see that there is a 1.01 Hotfix but still that doesn't change anything. I messed with the nglide settings and the compatibility as well. It crashes right after the 3dfx logo no matter what changes I have made.
avatar
mmax2: I had similar problem. Except it doesnt crash, but remained black screen instead of menu.
I solved it by deleting/renaming "opengl32.dll" in "Homeworld Emergence\3Dfx\WinNT"
And downloading the right "opengl32.dll" for your OS from here:
http://www.dlldownloader.com/opengl32-dll/
and placing it in its folder "Homeworld Emergence\3Dfx\WinNT"
Hope it helps
It really helped! Worked perfectly, THANKS!
A note for anyone else who runs into this problem in the future, Shukaku's solution is what finally got Homeworld Emergence working for me.

Hopefully people will continue to find it here.
avatar
Cheezowhiz: Same Problem. I reached out for help. I was told to download some old direct x drivers, update my graphics card drivers and reinstall the game. I see that there is a 1.01 Hotfix but still that doesn't change anything. I messed with the nglide settings and the compatibility as well. It crashes right after the 3dfx logo no matter what changes I have made.
avatar
mmax2: I had similar problem. Except it doesnt crash, but remained black screen instead of menu.
I solved it by deleting/renaming "opengl32.dll" in "Homeworld Emergence\3Dfx\WinNT"
And downloading the right "opengl32.dll" for your OS from here:
http://www.dlldownloader.com/opengl32-dll/
and placing it in its folder "Homeworld Emergence\3Dfx\WinNT"
Hope it helps
It worked perfectly, thank you
avatar
mmax2: I had similar problem. Except it doesnt crash, but remained black screen instead of menu.
I solved it by deleting/renaming "opengl32.dll" in "Homeworld Emergence\3Dfx\WinNT"
And downloading the right "opengl32.dll" for your OS from here:
http://www.dlldownloader.com/opengl32-dll/
and placing it in its folder "Homeworld Emergence\3Dfx\WinNT"
Hope it helps
avatar
Firerush: It worked perfectly, thank you
This was not only an easy fix but it should be one that GoG recognized and fixed themselves. You are a savior.