It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hello fellow Linux gamers!

Here you’ll find scripts allowing you to build packages for Debian, Arch Linux and any derivative (Ubuntu, Manjaro, Linux Mint, etc.) from your GOG installers for Heroes of Might and Magic games.
You will then be able to easily install these packages with you favourite packages manager.

Download links and usage instructions can be found on the following pages:
Heroes of Might and Magic
Heroes of Might and Magic II
Heroes of Might and Magic III
Heroes of Might and Magic IV
Heroes of Might and Magic V
Heroes Chronicles


I hope you’ll enjoy the ease-of-use provided by these scripts as much as I enjoy writing and tweaking them ;)

Here you go for more supported games!

-----

Salut camarades Linuxiens !

Vous trouverez ici des scripts vous permettant de construire des paquets pour Debian, Arch Linux ou n’importe quelle distribution dérivée de celles-ci (Ubuntu, Manjaro, Linux Mint, etc.) à partir de vos installeurs GOG pour la série Heroes of Might and Magic.
Ces paquets pourront ensuite être installés facilement via votre gestionnaire de paquets habituel.

Les liens de télechargement et les instructions d’utilisation se trouvent sur les pages suivantes :
Heroes of Might and Magic
Heroes of Might and Magic II
Heroes of Might and Magic III
Heroes of Might and Magic IV
Heroes of Might and Magic V
Heroes Chronicles

J’espère que vous apprécierez le confort apporté par ces scripts autant que j’apprécie les écrire et les améliorer ;)

Pour plus de jeux, rendez-vous par ici !
Post edited September 17, 2017 by vv221
Update

Better handling of WINE dependency on Debian-based systems (HoMM 3, 4 & 5)
Update

New supported installers for HoMM 3:
setup_homm_3_complete_4.0_(10665).exe
setup_homm_3_complete_french_4.0_(10665).exe
Post edited July 26, 2017 by vv221
Hi, thanks for the scripts! I'm using the one for HOMM 5 Tribes of the east.
The game plays pretty good but after some time in the game it starts to slow down pretty badly.
I can only exit the game and restart it.
This happens with every graphic configuration.
avatar
NightmareCC: (…)
I think I’ve seen this bug: after a random time the game slows down to some kind of slideshow, and the only work-around are to restart the game, or switch to another resolution (granted that you manage to navigate the game mnus without getting mad at its absence of responsiveness).

It didn’t happen something like one or two years ago, the last time I checked this game. So it might very well be related to some WINE update. (or a graphic driver update)

Sadly I still haven’t found out what is causing this and how to avoid it. If you manage to find anything, please tell me so I can update the scripts ;)

-----

Not sure about this, but this might be our bug:
https://bugs.winehq.org/show_bug.cgi?id=38166

I’ve seen this bug only on a setup using an nVidia GPU, is it the same for you?
Post edited August 17, 2017 by vv221
avatar
NightmareCC: (…)
avatar
vv221: I think I’ve seen this bug: after a random time the game slows down to some kind of slideshow, and the only work-around are to restart the game, or switch to another resolution (granted that you manage to navigate the game mnus without getting mad at its absence of responsiveness).

It didn’t happen something like one or two years ago, the last time I checked this game. So it might very well be related to some WINE update. (or a graphic driver update)

Sadly I still haven’t found out what is causing this and how to avoid it. If you manage to find anything, please tell me so I can update the scripts ;)

-----

Not sure about this, but this might be our bug:
https://bugs.winehq.org/show_bug.cgi?id=38166

I’ve seen this bug only on a setup using an nVidia GPU, is it the same for you?
Yeah I'm using an nvidia card.
If I find a solution I will let you know
avatar
NightmareCC: (…)
You might give a try to the open-source "nouveau" driver if you’re using the "nvidia" driver.
Even if you don’t want to stick with it afterwards, it might help us to know if it is a driver-related bug.

Another thing would be to try the developement version of WINE (2.14) if you’re using the stable version (2.0.2) or an older one.
You will be able to switch back to your usual version afterwards, but it would give us a hint about wether this bug will be fixed in the next WINE version or we will need to wait longer.

On my side I won’t be able to access a computer with a nVidia GPU soon, but when I do I’ll run some tests to see if I can pinpoint the origin of this bug.
Update

Arch Linux (and derivatives) support added for Heroes of Might and Magic V: Tribes of the East
New supported games: Heroes Chronicles (all chapters)
Post edited September 17, 2017 by vv221
Update

Heroes Chronicles will run in a WINE virtual desktop on first launch, avoiding messed up display on GPU drivers with poor compatibility for low 4:3 resolutions.
On Ubuntu 16.04 I'm getting the following:

leszek@leszek-MS-7758:~/Downloads/GOG/HOMM3$ sh ./play-heroes-of-might-and-magic-3.sh
Using setup_homm_3_complete_4.0_(10665).exe
Checking integrity of setup_homm_3_complete_4.0_(10665).exe OK
Extracting data from setup_homm_3_complete_4.0_(10665).exe
Warning: Unexpected setup data version: 5.5.7 (unicode)
Warning: Unexpected Privileges value: 4
Stream error while parsing setup headers!
├─ detected setup version: 5.5.7 (unicode)
└─ error reason: basic_ios::clear: iostream error
If you are sure the setup file is not corrupted, consider
filing a bug report at http://innoextract.constexpr.org/issues
Done with 1 error and 2 warnings.


What should I do? Thanks in advance for any pointers!
avatar
Elwro_RPGCODEX: (…)
It seems the version of innoextract provided in the Ubuntu 16.04 repositories is too old to extract the data from the new installer for HoMM3.

The following PPA will allow you to install a more recent version of innoextract:
[url=https://launchpad.net/~arx/+archive/ubuntu/release]https://launchpad.net/~arx/+archive/ubuntu/release[/url]
(sorry, the GOG forum breaks this link for some reason, you have to copy/paste it)

Here are the commands to use this PPA and install the newer version of innoextract:
sudo add-apt-repository ppa:arx/release
sudo apt-get update
sudo apt-get install innoextract
Post edited October 10, 2017 by vv221
Thank you very much, this did the trick! Now I need to find a way to resize the window :-)
avatar
Elwro_RPGCODEX: Thank you very much, this did the trick! Now I need to find a way to resize the window :-)
You might have to switch your screen resolution to something lower prior to running the game (I do this with xrandr), or to find a mod allowing to run the game in higher resolution than 800x600.

Here is the kind of script I use to run the game in full screen:
#!/bin/sh
set +e

xrandr --size 800x600
/usr/local/games/heroes-of-might-and-magic-3
xrandr --size 0

exit 0
Thank you again!