It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Era platform for Heroes 3 is the ultimate goodie. After installing it, you get to download more than 150 original mods, all of them tested and running smoothly. You can run most of them at same time, and your gaming experience will be greatly improved.

For preview check Heroes Community, Era II thread.
eralogo.png (134 Kb)
Post edited June 01, 2015 by Salamandre1970
I've just installed Homm3 and wog mod 358f and they work like a charm but I am unable to install the New Objects version 1.09 onto the game. I've tried umpteen times to do this after uninstalling, and re-installing the game, with the same result. I've made over 50 maps that use the objects on that patch and they don't work well, if at all with this GOG game. I have a ton of the following texts in my temp file in C:/ ...... Do these texts refer to the game installation?

"ERROR: A critical error occured while converting genuine authorization tickets on disk licenses.
Error code: 0x80041014.
ERROR: Failed! Error 0x!08X."

Does this have to do with the install code being written by GoG instead of what was on the original file?
How do I fix this?
Thanks. M
Post edited January 13, 2016 by emelpee
Nice expansion
Lag / delay.

Hey guys and girls.
For some reason, the wog and era expansions are running really bad on my PC. I have a toptuned gamer PC. But the game "lags". its delayed in its movements. I have no idea how to fix it. I have been searching the net for answers, but found none.
If anyone have an idea or know how to fix I would be so glad ! :)

I use the 3.58 wog
and I have the era start menu.
and I have the HD startup thing.

I tried the HD mod to see if it worked, but it didnt.

Help please!