It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Niggles: hi all,
Downloaded the massive 1.4 patch and that installs fine.
Downloaded 1.4.1 and when i had tried it , wont install
Now i try to redownload it and comes up with unable to fetch.
Is there a problem with this small patch/hotfix/whatever its meant to be?


-- > patch 1.4.1 will download via browser but not through gogdownloader.
---> tried with new download but patch at end of attempted install
"Hard West patch log
Update from version to

File not found (for copying): V:\GOG2\Hard West\32\HardWest_Data\Plugins\Galaxy.dll
File not found (for copying): V:\GOG2\Hard West\64\HardWest_Data\Plugins\Galaxy64.dll
Incorrect version of: V:\GOG2\Hard West\32\HardWest_Data\level45
Incorrect version of: V:\GOG2\Hard West\32\HardWest_Data\level46"

thats from the error log ( installed fine).
Only thing I recommend as of right now would be to uninstall (keep your saves!) and reinstall and see if anything changes.