It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've recently been playing through this game and enjoying it quite a bit. However, I've encountered what appears to be a dead end, making the "In Gold We Trust" campaign impossible at the moment.

(Some spoilers included, of course...)

Having reached the far north end of the map, and at the point where I have the three native camps to slaughter and the excavation site available, I also have access to the graveyard and the caravan (plus the remaining resources such as the hunting grounds, fate traders, mine, riverbank and village).

Once the caravan and graveyard have been robbed, I can then slaughter all of the native camps, and complete the excavation, which makes the old church available. I go there, get the mask (and whether or not I cross myself, I end up being poisoned, apparently?) and then access the fight back at the camp.

So far, so good, but having completed the rescue and killed off the enemies/ex-friends at the camp, I gain all of the extra cards and goodies from this, but nowhere new appears on the world map.

I still have access to the two fate traders, hunting grounds, mine, riverbank and village, and of course my camp, but there don't seem to be any new missions or locations unlocked, so I'm left wandering around the world map with nothing to do.

The first time this happened, I tried exiting the menu, but when I reloaded, I was returned to the point before I'd cleared out the native barrows.

I've just played through the whole section again (this time losing a posse member in the battle and burning down the hunting grounds, though otherwise doing everything pretty similarly), and the same thing has happened again.

I think this makes the scenario impossible for me at the moment - is this a known bug? If so, is there a workaround, or possibly a patch planned?

Would be cool to be able to get on and complete the game. :)
Post edited June 23, 2018 by 13685
No posts in this topic were marked as the solution yet. If you can help, add your reply
J'ai exactement le même problème... Si c'est un bug, en 2023 il n'est toujours pas réglé !

Traduction par Google :
Good morning,
I have exactly the same problem... If it's a bug, in 2023 it's still not fixed!