It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hello everyone,

I'm almmost thorugh the As Good As Dead-Scenario, but when I try to start the assault on the Masked Man, after the equipment screen I just get a black screen with only the Esc-Button in the upper right corner visible. I've aready tried running Windows 8-compatibility mode and turning all graphics options to the lowest level.

Any tips are appreciated.

EDIT: Verifying and repairing the game files didn't help either.
EDIT: I also experience the slowdonw in the game after it has been running awhile, even though it is using the dedicated GPU..
Post edited August 25, 2019 by J.Jordan
No posts in this topic were marked as the solution yet. If you can help, add your reply
SOLVED (or rather WORKAROUND): I found a tip to try and play through the scenario in one sitting (no exiting, saving, whatever), and it worked out. Not very convenient, but I'm glad I could finish the scenario.

Also, activating VSYNC seemed to alleviate the slowdown somewhat.

EDIT: Now, achievements seem to be damaged. I didn't get the achievement for completiing AGaD or A Matter of Time (which I played afterwards). At this point, I don't care much about achievements, fortunately, and am just happy to be able to continue the game, cause apart from the quirks, bugs and sparing support on the forums, I like it quite a lot. X-D
Post edited August 26, 2019 by J.Jordan