It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Greetings

Played the game over a year ago (before wildcards DLC, for example) and the whole thing worked fine...

I use Wired usb X360 controllers (official microsoft, not third party one)

Yesterday i installed the game on a different computer, with latest GOG version, and i have the following problems
1) Game keep displaying me Playstation buton prompts since the game start and through every parts of game... But in settings menu, on control tab, it does display me the X360 silhouette and correct buttons in the layout picture

2) whenever i enter a merchant shop during play, most buttons barely work at all, i have to mash them or press them hard to ever get the selecting or cancelling/getting out commands working out fine. Sometimes i end up buying same item more than once after having tried 8 times to buy it once.

Went on the other computer, with the older version: was all fine... Updated the game there to latest GOG and got same problem. Uninstalled it completely and made a clean install and same problem

Checked with a friend who has the gog version too, he doesnt get the issue, we checked executable size and version, it's all the same. he uses wired x360 too. Only difference between us is that he had the game updated through GOG Galaxy ( and i dont use galaxy, it is not installed on either/both computers i tested it on)
One computer is on a clean Win7 pro x64, the other on a Win8 home x64 (the one which had old version)

So, always get PS4 buton prompt (disturbing but not gamebreaking, except it used to work, before,in 1 year ago version), and butons barely work when in shop (way more problematic)

Saw a streamer play the game a couple of nights ago, presumably used the steam version (as the person barely ever know about GOG or drm-free matters at all) and he had X360 butons prompts on screen.

Thank you for help

PS: searched a bit for support on steam forum (as it seems it's the only thing to do, usually) and a dev answer was that latest 1.3.18 version supposedly fixed the issue. Seems GOG 1.3.18 didnt, for me at least.
No posts in this topic were marked as the solution yet. If you can help, add your reply