It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Stickied for graet justice! :D
Norgur8: Hi,

Recently I installed G2: Gold. The game was running beautifully until I got outside Xardas' tower. Frames tanked to 20-30 range. Looked around for a solution on steam forums, here on gog, wog, etc. Most people were reporting issues with nVIDIA cards (that was supposedly fixed with newer drivers) but I have an AMD 5870.

I downloaded an application called GPU-Z that shows how the card is performing. I ran it in the background while playing Gothic 2 and noticed that the core clock and memory clock were running on 2D settings. Newer cards downclock themselves if no 3D application is running to save power.

It seems like AMD Catalyst does not consider G2 to be a 3D application. So I made a profile for G2 in Catalyst - turned on AA and AF (both 2x). Core and memory clocks run at 100% while running G2, so I get smooth 60 FPS outdoors as well.

So far no issues after playing for 5 hours. Sometimes when pressing Esc the world will get a litle darker but can be easily fixed by pressing Esc again (happens for the first time whenever playing G2).

TL;DR: Turn on some small graphical goodies in Catalyst Control Center under Gaming tab -> 3D Application Settings -> Add profile for Gothic 2
See here:

Just wanted to say thanks for finding out how to work out this issue :D.
Post edited February 25, 2013 by JudasIscariot
JudasIscariot: See here:

Just wanted to say thanks for finding out how to work out this issue :D.
Arkose: Just as a note, you might want to specify "AMD/ATI" (or the like) since the ATI name hasn't actually been used for a couple of years now (everything since then uses the AMD name).
Thanks, I'll pass that on to our Support team :D.