It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Okay reported this as a bug via the report issues feature, but can't find where I can update my report, so I'm updating here.

I installed GoG 2.0, connected it with my steam library and launched Conan Exiles. Got an error saying a couple of mods (only three on the server I play on) didn't validate properly, but reloaded the mods and was able to log into server. Logged out to get supper, and after supper Steam wanted to update. I closed it down at first, foolishly thinking that Galaxy 2.0 would launch the game without Steam running. Hah. Stupid me.

I ran Conan, Steam started, updated and loaded the game. I got the error message again, and went to the mods option in Conan to reactivate the offending mods. But now not only are the two mods in question not validating, but it doesn't even see them. More alarmingly, I couldn't find any servers, as though I was offline.

I exited the game and switched to Ark Survival Evolved. Not only couldn't I see any servers, but it now wanted to redownload and install 19 mods. Steam copy of Stellaris is the same deal.

So I tried to launch them from Steam. Nope. Steam keeps trying to download all the "missing" mods - they are in fact still there on my hard drive, but neither client sees them. Steam keeps trying to redownload them, downloading them and then losing them again.

I quit out of Galaxy and tried just using Steam, but that didn't work. I tried restarting the computer. I tried running Galaxy with admin privileges with no success. Skyrim SE will connect to Bethesda's mods and creation club, and Online games still get online, but my connection to the workshop seems irrevocably broken.

I'm getting pretty desperate, here. I admin two servers for Ark and need to be online asap. Gonna try uninstalling Galaxy, but I don't have much hope of that working. Anyone got any advice?

Edit - just tried disconnecting Steam from Galaxy. Didn't solve it. Sigh. Uninstalling Galaxy....

Edit 2 - It's not lost on me that Steam updated. It could be that Steam broke the connection. Wouldn't be surprised. Uninstalling Galaxy didn't help. Reinstalling.

Edit 3 - Resetting the router solved the problem for two of the games, it seems. Only Ark remains the holdout.
Post edited August 07, 2019 by PhillipEarl
No posts in this topic were marked as the solution yet. If you can help, add your reply