It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

What the title say, I can't update games since yesterday (it displays "Updating 0%" and a rotating circle but doesn't change); I just tried installing a game today and the dialog box shows up but it's empty and the install button is grayed out.

looking at GalaxyClient.log whenever I launch a game update I see a lot of

2022-05-12 16:14:10.376 [Error][ (0)] [TID 16252][galaxy_client]: An error occurred, Other, while performing request (requestId: 8723) for URL '[[[REDACTED]]]' after 21052 ms. Exception: Timeout (), code=10060

the URL it's failing to reach is "[url=][/url]/" + a string of random characters I'm not posting in case it's sensitive info. I can't reach by ping so maybe it's just some of the GoG infrastructure being down? or that URL is now obsolete but my local galaxy install doesn't know?

I'm running v2.0.50.34, which the galaxy autoupdate claims is the latest
Post edited May 12, 2022 by cafeine_
the problem seems to have solved itself? the games in my library are updating now, and the install button is clickable.

Error messages would a huge usability improvement, if it's a server issue just pop a "Can't reach update server" error box so users don't waste time trying to figure out what's wrong.
I faced the same issue, and I was able to fix it by:

1. Completely close GoG Galaxy.
2. Disable IPv6 (search how to disable IPv6 in your OS online).
3. Open GoG Galaxy.


I figured this out by examining C:\ProgramData\\Galaxy\logs\GalaxyClient.log which had the following error:

> [Error][ (0)] [TID 6132][galaxy_client]: An error occurred, Other, while performing request (requestId: 238) for URL '{redacted}' after 10003 ms. Exception: Timeout (connect timed out: [2001:1900:2318:1f03::2]:443), code=0
> [Error][ (0)] [TID 11820][galaxy_client]: Unable to get response for request url {redacted}. Response code Uninitialized.

You can see that the IP address shown there is IPv6, disabling it on my machine did the trick.
Post edited June 03, 2022 by marcogrcr