It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
avatar
AWG43: Pathfinder: Kingmaker DLCs cannot be installed now due to compatibility issue with the game (different file versions - game files are 23987, while the DLCs are 23963). Made a support ticket.
all files (win) should be 24012 / version 1.0.1
avatar
Geralt_of_Rivia: Diluvion: Resubmerged

Updated from 1.2.31 to 1.2.33. No changelog.
avatar
MarkoH01: Maybe they just renamed the files? I was wondering why the versions were different on Galaxy and the offline installers when the Resubmerged version first was released. Sure this mystery will be solved shortly.
It's because we got a last minute update to the game that day. We had a working and tested set of installers available so we published those and then updated them after we tested the new update :)