It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Random question: has anyone gotten Myst IV - Revelation working? I know I've gotten it to work in WINE in the past, but I just tried to reinstall it now (running in WINE 3.5) and the game hard freezes when I try to use the camera after the opening cinematic.
Post edited May 21, 2020 by rampancy
avatar
dtgreene: What's the current state of Bloodstained? Does it run well in Wine?

(Also, does the game drain your battery significantly? I want to know to gauge whether I would have to worry about my desktop overheating; games like Hollow Knight and Crosscode can make it overheat and throttle, while Timespinner and Celeste do not, but then again, those 4 games run without Wine.)
You probably have the response by now but anyway:
I did try Bloodstained on Windows a while ago and it seemed a bit heavier on resources than Hollow Knight, not sure how it translate to Wine but is way more graphical intensive than Celeste and Timespinner.
avatar
dtgreene: What's the current state of Bloodstained? Does it run well in Wine?

(Also, does the game drain your battery significantly? I want to know to gauge whether I would have to worry about my desktop overheating; games like Hollow Knight and Crosscode can make it overheat and throttle, while Timespinner and Celeste do not, but then again, those 4 games run without Wine.)
avatar
Dark_art_: You probably have the response by now but anyway:
I did try Bloodstained on Windows a while ago and it seemed a bit heavier on resources than Hollow Knight, not sure how it translate to Wine but is way more graphical intensive than Celeste and Timespinner.
Actually, I didn't get any response back then, and unfortunately the sale has ended some time ago.

(In particular, I still don't have an answer about Wine compatibility.)
avatar
rampancy: Random question: has anyone gotten Myst IV - Revelation working? I know I've gotten it to work in WINE in the past, but I just tried to reinstall it now (running in WINE 3.5) and the game hard freezes when I try to use the camera after the opening cinematic.
Wine 3.5 is quite old, you should upgrade. I've just checked it with wine-staging 5.7 and didn't get any freezes after the intro. (The game first complained about my hardware being "incompatible" but seems to launch as normal).
Huh. I expected this to have been asked by now...

Do Arkane's Prey and Dishonored games work under Wine?

Edit: Wow, the linking feature is pretty broken... doing this more manually...

* https://www.gog.com/game/prey_digital_deluxe_edition
* https://www.gog.com/game/dishonored_complete_collection
Post edited June 01, 2020 by Shadowcat
avatar
Shadowcat: Do Arkane's Prey and Dishonored games work under Wine?
If you quote my post, you should see how you can post multiple links on a same line. The inner space after the opening url tag is what does the trick.
avatar
vv221: If you quote my post, you should see how you can post multiple links on a same line. The inner space after the opening url tag is what does the trick.
Thank you! I would never have tried doing that.
avatar
xixas: Game: X3: Terran War Pack
...
Winetricks: amstream devenum quartz wsh57 wmp10
Extras: Microsoft ActiveMovie - "amov4ie.exe" available from PlayOnLinux or Lone Wolf $cripts (installed last)
I don't suppose you tried this with winetricks -q wmp9 instead? Active Movie is pre-WMP so I'm surprised it's needed after WMP is installed. The wmp9 install also includes the the legacy 7 codecs. I'm assuming it's a missing interface and not a codec issue, but it's possible wmp9 with the legacy 7 codecs includes it? It's also quite possible it doesn't.
Post edited June 07, 2020 by Gydion
Has anyone succeeded to run the GOG version of Supreme Commander on Wine?

All I get is a black screen with a cursor and sound. I've tried to install all of the dx9 escalations up to directx9, have tried to use an emulated desktop and have switched off the bloom render in the game config, without success. Any ideas?

SC Forged Alliance works out of the box and I could play the tutorial without problems.
avatar
eiii: Has anyone succeeded to run the GOG version of Supreme Commander on Wine?

All I get is a black screen with a cursor and sound. I've tried to install all of the dx9 escalations up to directx9, have tried to use an emulated desktop and have switched off the bloom render in the game config, without success. Any ideas?

SC Forged Alliance works out of the box and I could play the tutorial without problems.
Yes...if you give me a second or two, I'm going to post a report formatted as per Gydion's instructions.
avatar
Gydion: I don't suppose you tried this with winetricks -q wmp9 instead? Active Movie is pre-WMP so I'm surprised it's needed after WMP is installed. The wmp9 install also includes the the legacy 7 codecs. I'm assuming it's a missing interface and not a codec issue, but it's possible wmp9 with the legacy 7 codecs includes it? It's also quite possible it doesn't.
In my initial experiments I tried both wmp9 and wmp10, though both attempts crashed at the intro (logo) video. Removing the intro video file allowed the game to load up (the cinematics didn't play, but they skipped without crashing). Once in game, though, all the popup videos were blank and also triggered gstreamer WMA (audio) missing plug-in errors in the log.

ActiveMovie was required to get the intro video to play (and not crash out) and get the in-game character videos playing. By the time I reached that point, though I don't think I ever went back and tried wmp9 + ActiveMovie.
avatar
rampancy: Yes...if you give me a second or two
You may even have a minute or two. :P

No hurry, take your time, I'm already busy playing FA. :)
Post edited June 09, 2020 by eiii
Game: Supreme Commander
Installer MD5s:
setup_supreme_commander_1.1.3280_(37763).exe = a793f17248dfb579649457f09d221cd5
setup_supreme_commander_1.1.3280_(37763)-1.bin = 330f95514816e46f1fdad40425b94186
setup_supreme_commander_1.1.3280_(37763)-2.bin) = 69e76dde2f9eb7ff1395b2b4e67da958

WineHQ AppDB link: https://appdb.winehq.org/objectManager.php?sClass=version&iId=7038
CodeWeavers link: https://www.codeweavers.com/compatibility/crossover/supreme-commander

Distro/Desktop: Mac OS X 10.14.6 Mojave
Kernel version: 18G4032
Graphics card: Intel HD Graphics 6000 (1536 MB)
Wine version(s) tested: 4.12.1 (Works); Doesn't work in Wine 5.7, 5.7 (Staging)
Install notes:

I used the following winetricks, taken from the latest test report for the AppDB page for its expansion, Forged Alliance:
tahoma flash vcrun2010 dotnet40 corefonts d3dx9 d3dx9_36 xact

How well does it run:

The game doesn't seem to run in Wine 5.7, or 5.7 Staging, though it does run perfectly well in Wine 4.12.1 and CX 19.0.1 (which is based off of 4.12.1). Performance is good in full screen @ 1440 x 900, with graphics settings set to the defaults, however I haven't progressed far enough into the game when hundreds of units/buildings are in play at once.
avatar
rampancy: Yes...if you give me a second or two
avatar
eiii: You may even have a minute or two. :P

No hurry, take your time, I'm already busy playing FA. :)
Ha ha, you are far too gracious, good sir. :)
Post edited June 10, 2020 by rampancy
avatar
xixas: ActiveMovie was required to get the intro video to play (and not crash out) and get the in-game character videos playing. By the time I reached that point, though I don't think I ever went back and tried wmp9 + ActiveMovie.
I was only interested in if wmp9 might obviate the need for ActiveMovie, but if it doesn't then no worries.
avatar
rampancy: Game: Supreme Commander
...
Distro/Desktop: Mac OS X 10.14.6 Mojave
Kernel version: 18G4032
Graphics card: Intel HD Graphics 6000 (1536 MB)
Wine version(s) tested: Wine 5.7, 5.7 (Staging), 4.12.1, CX 19.0.1
Install notes:

I used the following winetricks, taken from the latest test report for the AppDB page for its expansion, Forged Alliance:
tahoma flash vcrun2010 dotnet40 corefonts d3dx9 d3dx9_36 xact

How well does it run:

The game doesn't seem to run in Wine 5.7, or 5.7 Staging, though it does run perfectly well in Wine 4.12.1 and CX 19.0.1 (which is based off of 4.12.1).
To clarify Wine version(s): should be listing the working versions. Obviously, it's useful to mention non-functioning versions you tried where you do. What Wine builds are you using anyway? Wine on OS X has been rough these last several releases.

Looking at the AppDB I see no reason for the flash verb and does it actually need tahoma? The linked font bug is about 'Courier New' and not tahoma.
Post edited June 10, 2020 by Gydion