It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
So I'm new to GOG but, I installed the game just fine and now when I download the patch v1.03 it installs successfully but when I launch the game it still shows as v1.02. what am I doing wrong and how can I fix this?
avatar
Ragingtabor: So I'm new to GOG but, I installed the game just fine and now when I download the patch v1.03 it installs successfully but when I launch the game it still shows as v1.02. what am I doing wrong and how can I fix this?
Hey, you may have more luck in the witcher 3 subforum but just wanted to say the same happened to me actually. If you are using galaxy, make sure next to the "More" section, it says "Installed", if so hover over it and click view change log to see if it is indeed 1.0.3. If not all i can suggest would be a reinstall perhaps. Try the witcher 3 sub forum first though.
avatar
Ragingtabor: So I'm new to GOG but, I installed the game just fine and now when I download the patch v1.03 it installs successfully but when I launch the game it still shows as v1.02. what am I doing wrong and how can I fix this?
avatar
WhiskeredWolf: Hey, you may have more luck in the witcher 3 subforum but just wanted to say the same happened to me actually. If you are using galaxy, make sure next to the "More" section, it says "Installed", if so hover over it and click view change log to see if it is indeed 1.0.3. If not all i can suggest would be a reinstall perhaps. Try the witcher 3 sub forum first though.
Yea I thought I was in the sub forum already my bad. I had not used galaxy at all to install the game in the first place. I did a manual install.