It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
high rated
avatar
JTQuincy: Go to C:\ProgramData\GOG.com\Galaxy\lock-files and delete the GalaxyClient.exe.lock file and try launching Galaxy again
Thank you !
Fix for this issue was released with 2.0.43 version :)
avatar
Johny.: Fix for this issue was released with 2.0.43 version :)
I'm still getting this error
avatar
JTQuincy: Go to C:\ProgramData\GOG.com\Galaxy\lock-files and delete the GalaxyClient.exe.lock file and try launching Galaxy again
avatar
HotdogPotato: Thank you !
This worked - thanks!
Post edited October 02, 2021 by snbModigy
avatar
Johny.: Fix for this issue was released with 2.0.43 version :)
avatar
snbModigy: I'm still getting this error
avatar
HotdogPotato: Thank you !
avatar
snbModigy: This worked - thanks!
You're sure that you were on 2.0.43?
avatar
snbModigy: I'm still getting this error

This worked - thanks!
avatar
Johny.: You're sure that you were on 2.0.43?
I'm on 2.0.43 and I keep getting the same popup every time I start the laptop. I can see 2 files in:
C:\ProgramData\GOG.com\Galaxy\lock-files

GalaxyClient.exe-galaxy-client.lock
GOG Galaxy Notifications Renderer.exe.lock

Gonna delete the first one and see if it occurs again. If it does I'll report back.

Edit 1:
Deleting the first file alone did not work, relaunched it and got the popup again.

Edit 2:
Deleted the second one, relaunched it, and didn't get the error.

Edit 3:
After booting up the laptop again today, I got the same message again. I can see both the files are back in the same folder. Maybe a reinstall will help.
Post edited October 14, 2021 by ev1lsyk0
I just ran into the same problem and doing a simple direct download-and-install from the website fixed it. For now. The current version it installed (Oct 20, 2021) is 2.0.38 so it looks like the fixed version mentioned above isn't actually released on the site yet.

*edit*
Just had a look and version 2.0.43 does list a fix for this issue, but it is still in beta.
Post edited October 20, 2021 by Alien_Bard
avatar
ev1lsyk0:
Can you please send your logs through https://mantis2.gog.com and let me know here that you did so? The instructions are on the top of the page.

Alternatively, you can use "report issue" button in the settings dropdown in the app, it should attach your logs automatically.
Post edited October 21, 2021 by Johny.