It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

strange the game runs perfectly to me
Devspar: Have anyone tried to use D3DWindower on GF 1-3 to fix the jerky problem?
I experienced the same jerkiness issues under XP Pro 32 bit, as well as the game taking forever and a day to either save/load or move between maps.

Applying the 'forceDirectDrawemulation' switch alone using the MS Compatibility Toolkit solved my problems with Geneforge 1. It runs like silky butta' now. Loads, saves and map transitions are instantaneous.
Post edited July 17, 2012 by Candew
A bit late in the day but I'm also using XP Pro SP3 32-bit and the fixes shown didn't work for me.

I added ForceDXsetupsuccess and Heaplookasidefree and now it runs just fine.
rahal: Get Microsoft compatability administrator -> flag you need to set is ForceDirectDrawEmulation
Thanks for this suggestion. It worked like a charm on my XP machine.