It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Under "Backups & Goodies" the "Game backup copy" defaults to German and if I change the language (to any of them) after a few seconds it flips back to German.

Other games with multiple language options are NOT doing this.
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Skolia: Under "Backups & Goodies" the "Game backup copy" defaults to German and if I change the language (to any of them) after a few seconds it flips back to German.

Other games with multiple language options are NOT doing this.
I've noticed the same issue except it affects more than just GalCiv 3.

I did some experimenting using GalCiv 3 and Gwent. What I found is that the "Game backup copy" defaults to German and also resets from English back to German any time that the UI updates. This includes status notifications e.g. Updating --> Updating failed/finished/etc.


Update: Found that Issue 0005150 is tracking this bug.
http://mantis.gog.com/view.php?id=5150
Post edited August 14, 2017 by kprof