It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
I was happy when a new improved GK2 installation got available because I had some minor sound problems with the old version. But now, after the new installation I have much more trouble:
- The game takes very long to launch
- The music and sounds have much more crackles and pops than before
- The music and sounds during FMV-sequences are constantly stuttering
The good thing is the quality of the graphics has slightly improved. But in the current condition GK2 is nearly unplayable. I hope someone can solve this problems!
Best regards,
Chris
Hardware information:
Operating system: Windows XP Home Edition (5.1, Build 2600) Service Pack 3
Processor type and speed: Intel(R) Atom(TM) CPU N280 @ 1.66GHz (2 CPUs)
RAM memory: 1016MB RAM
Graphics card: Mobile Intel(R) 945 Express Chipset Family
Sound card: Realtek HD Audio
Graphics driver version: 6.14.0010.4906 (English)
DirectX version: DirectX 9.0c (4.09.0000.0904)
This question / problem has been solved by Collectorimage
Have you tried the fixes listed in this thread
[url=]http://www.gog.com/en/forum/gabriel_knight_series/poor_sound_quality_in_gabriel_knight_2[/url]
If they don't work you could also try turning off sound hardware accelertion. To do this just click start menu, then run and type in dxdiag. Once thats loaded up go to the sound tab and move the sound hardware slider so its set to off and then save the changes.
avatar
Ralackk: Have you tried the fixes listed in this thread
[url=]http://www.gog.com/en/forum/gabriel_knight_series/poor_sound_quality_in_gabriel_knight_2[/url]

Thx, but most solutions suggested in this thread only apply to the older installation of GK2 and should already be applied to the new version. That's why I'm a little bit confused. The older installation worked better (after some tweaking) than the new one (with the tweaks already applied)! I wish I never had installed the new GK2... :-)
avatar
Ralackk: If they don't work you could also try turning off sound hardware accelertion. To do this just click start menu, then run and type in dxdiag. Once thats loaded up go to the sound tab and move the sound hardware slider so its set to off and then save the changes.

Turning off the sound hardware acceleration makes the sound quality even worse, but it was worth a try!
I'm not sure why they did it, but they changed the RESOURCE.CFG. They set the music to an MT-32. Not only is the soundtrack not optimized for an MT-32, but without one connected to your PC it will sound horrible. It is also why it taking so long to initialize the game. It is trying to send SysEx data to an MT-32. They also removed the MIDNONE.DRV for some inexplicable reason. This is what is required for the digital music. If you still have your old installation, copy the MIDNONE.DRV to the new folder and edit the RESOURCE.CFG to change the soundDrv = MT32.DRV to soundDrv = MIDNONE.DRV.
If you don't have the MIDNONE.DRV, let me know and I can upload itto my site.
Edit: OK, I've had a chance to look at a little closer and found out what happened. Rather than use my patch, they followed my instructions to manually fix the game and deleted the MIDNONE.DRV with all of the duplicate patch files in the game's base folder. This causes the game to game to crash on launch. Rather than to investigate what they did wrong they just dropped in a bunch of audio drivers form another game. Rarely can you use drivers from another game and have it work. The MT-32 driver was the only one that worked, but only with distorted sound and wrong instruments. I guess that I will throw together another patch to fix this release.
Here it is:
http://sierrahelp.com/Patches-Updates/GOGUpdates.html#GOGGK22
Post edited March 10, 2010 by Collector
avatar
Collector: I guess that I will throw together another patch to fix this release.
Here it is:
http://sierrahelp.com/Patches-Updates/GOGUpdates.html#GOGGK22

Wow, thank you very much for your efforts! I tried the patch but I fear it doesn't work completely for me: The game launches much more quickly now, but the sound/music in the FMV-sequences keeps on stuttering. The sound/music in the in-game sequences is ok though...
I was wondering if it could be driver issue. I also have XP with SP3 and Realtek HD Audio and neither GOG versions of GK2 have had any problems with the latest Realtek audio drivers.
avatar
OlausPetrus: I was wondering if it could be driver issue. I also have XP with SP3 and Realtek HD Audio and neither GOG versions of GK2 have had any problems with the latest Realtek audio drivers.

The GOG-support just wrote me that another new version of the GK2-installation is now available for download. I hope it works! But I will also try to update my audio drivers if possible and see if it works!
Still have to finish GK1, so waiting for a sufficiently working version of GK2 isn't too bad... :-)
Hello again!
I updated my audio drivers (as suggested by "OlausPetrus") and installed GK2 once again with the "new" new installation-files. Nothing has changed. The game still takes very long to launch (without the patch from "Collector"), the music and sounds are crackling and stuttering like hell and the music and sounds during FMV-sequences are still constantly stuttering. I hope GOG just provides the first version of the GK2-installation for download again. It wasn't perfect but good enough and playable!
avatar
ChristianHaH: Hello again!
I updated my audio drivers (as suggested by "OlausPetrus") and installed GK2 once again with the "new" new installation-files. Nothing has changed. The game still takes very long to launch (without the patch from "Collector"), the music and sounds are crackling and stuttering like hell and the music and sounds during FMV-sequences are still constantly stuttering. I hope GOG just provides the first version of the GK2-installation for download again. It wasn't perfect but good enough and playable!
I cannot duplicate your problem. This is just a shot in the dark, but I just noticed your processor specs. I'm assuming the this is a Netbook with that CPU. I'm not sure if your processor is choking on it or not. You said that the original version worked better for you. The main difference between the two versions is the Interlace patch and the lowering of the cycles. Lowering the cycles should have helped with the stuttering, so it may be the No-Interlace patch that your computer does not like. To remove the patch, go to http://sierrahelp.com/Patches-Updates/GOGUpdates.html#Interlace to download the original files that are replaced by the patch. Go to the PATCHES folder and remove 11.hep. 11.scr, 34.hep, 34.scr, 36.hep, 36.scr. You may wish to back them up in a backup instead of just deleting them. Then unzip "Interlace.zip" into the PATCHES folder. To reapply the patch, just copy the above files back into the PATCHES folder.
avatar
Collector: I cannot duplicate your problem. This is just a shot in the dark, but I just noticed your processor specs. I'm assuming the this is a Netbook with that CPU. I'm not sure if your processor is choking on it or not. You said that the original version worked better for you. The main difference between the two versions is the Interlace patch and the lowering of the cycles. Lowering the cycles should have helped with the stuttering, so it may be the No-Interlace patch that your computer does not like. To remove the patch, go to http://sierrahelp.com/Patches-Updates/GOGUpdates.html#Interlace to download the original files that are replaced by the patch. Go to the PATCHES folder and remove 11.hep. 11.scr, 34.hep, 34.scr, 36.hep, 36.scr. You may wish to back them up in a backup instead of just deleting them. Then unzip "Interlace.zip" into the PATCHES folder. To reapply the patch, just copy the above files back into the PATCHES folder.

Yes, I'm using a netbook, the Asus EeePC 1005HA. But since the original-version of GK2 worked pretty well after some tweaks (except from only occasionally cracking and popping sound) I don't think the processor is choking on it. I removed the No-Interlace patch, like you suggested, but with no positive effect. The sound of the FMV-sequences keeps on stuttering permanently.
avatar
Collector: I cannot duplicate your problem. This is just a shot in the dark, but I just noticed your processor specs. I'm assuming the this is a Netbook with that CPU. I'm not sure if your processor is choking on it or not. You said that the original version worked better for you. The main difference between the two versions is the Interlace patch and the lowering of the cycles. Lowering the cycles should have helped with the stuttering, so it may be the No-Interlace patch that your computer does not like. To remove the patch, go to http://sierrahelp.com/Patches-Updates/GOGUpdates.html#Interlace to download the original files that are replaced by the patch. Go to the PATCHES folder and remove 11.hep. 11.scr, 34.hep, 34.scr, 36.hep, 36.scr. You may wish to back them up in a backup instead of just deleting them. Then unzip "Interlace.zip" into the PATCHES folder. To reapply the patch, just copy the above files back into the PATCHES folder.
avatar
ChristianHaH: Yes, I'm using a netbook, the Asus EeePC 1005HA. But since the original-version of GK2 worked pretty well after some tweaks (except from only occasionally cracking and popping sound) I don't think the processor is choking on it. I removed the No-Interlace patch, like you suggested, but with no positive effect. The sound of the FMV-sequences keeps on stuttering permanently.
Try playing around with the DOSBox cycles.
avatar
Collector: Try playing around with the DOSBox cycles.

Heureka! Lowering the cycles to 7000 finally did the job! Thx, Collector!
The MIDNONE.DRV is back too, so I just had to change the RESOURCE.CFG for improved launching times, just as you suggested!
I thought buying DOS-games on GOG would spare me the tampering around with DOSbox... guess I was wrong! :-D
Post edited March 12, 2010 by ChristianHaH
Collector.
I've got the same problems with sound as topic's creator.
So I've installed your path for 2-nd GOG edition.
Bravo! Sound is good now. All super. But there is always a but.
I have no subtitles anymore.
The language 351 is specified at the resource.cfg.
What can be wrong?
Many thanks in advance.
Edit:
Ok. I've install over it all again subtitles patch and sound is ok now, also subs are on.
But have same sounds problems in game, when reading/speking/commenting.
Will try to reduce cycles.
Edit:
Ok, 7K cycles helped. But game is so slow. Even during dialogue it's taking 1sec of blackscreen between changing camera (video file) from someone to Herr Knight.
Oh my.
Post edited May 30, 2010 by h0w1er
Try upgrading your DOSBox to 0.74
avatar
h0w1er: Collector.
I've got the same problems with sound as topic's creator.
I had some minimal problems with sound, and changing the buffer size from 10 to 100 cleared it up for me. Here's my setting under mixer.
[mixer]
nosound=false
rate=22050
blocksize=2048
prebuffer=100

While lowering the cycles helped initially, with a bigger buffer I'm able to use these settings:
[cpu]
core=dynamic
cycles=auto