It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
just need to mention this: http://www.wsgf.org/dr/gabriel-knight-3-blood-sacred-blood-damned

1- Open regedit and navigate to HKEY_CURRENT_USER\Software\Sierra On-Line\Gabriel Knight 3\Engine .

2- Edit the decimal value of these keys :
(default) = yyyy
Screen Height = yyyy
Screen Widht = xxxx

Where xxxx is desired width & yyyy is desired height.

(default) and "Screen Height" MUST have the same value.

not sure how well known this solution is...
avatar
fischkopf: I have now found a 1080p solution for older graphic DirectX 10 cards as well: http://www42.zippyshare.com/v/kfkasQUh/file.html

Get DxWnd, unzip to in a separate folder. Apply the regfix from my archive. Now open DxWnd as admin (this is important, otherwise it won't save the profile, next time you open it) go to File / Import and import the GK3 profile from the archive. Now you need to change the file paths, because the profile uses my paths. Right click on the profile and go to "modify". Change the paths so they match yours in the "launch" line, add this after the .exe (without quotes):

" -width 1920 -height 1080"

Now you can play GK3 in 1080p with your DirectX 10 graphics card.

This has a few downsides compared to the DirectX 11 method:

You need to run DxWnd everytime you want to run the game (no big deal I think)
ReShade doesn't work (you can force AA and Anisotropic filtering in your drivers anyway)
The mouse will leave trails in 2D menus (map screen, main menu, inventory, Sidney)

I wasn't able to fix the mouse trails, but I think this is still much better than playing the game in a much lower resolution. :)
The link to zippyshare is broken.
avatar
fischkopf: I have now found a 1080p solution for older graphic DirectX 10 cards as well: http://www42.zippyshare.com/v/kfkasQUh/file.html

Get DxWnd, unzip to in a separate folder. Apply the regfix from my archive. Now open DxWnd as admin (this is important, otherwise it won't save the profile, next time you open it) go to File / Import and import the GK3 profile from the archive. Now you need to change the file paths, because the profile uses my paths. Right click on the profile and go to "modify". Change the paths so they match yours in the "launch" line, add this after the .exe (without quotes):

" -width 1920 -height 1080"

Now you can play GK3 in 1080p with your DirectX 10 graphics card.

This has a few downsides compared to the DirectX 11 method:

You need to run DxWnd everytime you want to run the game (no big deal I think)
ReShade doesn't work (you can force AA and Anisotropic filtering in your drivers anyway)
The mouse will leave trails in 2D menus (map screen, main menu, inventory, Sidney)

I wasn't able to fix the mouse trails, but I think this is still much better than playing the game in a much lower resolution. :)
avatar
mlube: The link to zippyshare is broken.
I can't reupload the config right now, but you could try doing it yourself using dgVoodoo. DXwnd might be a bit trickier, you need to play around with the settings a bit and see what works.

Anyway, I wouldn't recommend playing through the whole game at a 16:9 format though because it messes up the Sydney screen and will at some point prevent you from progressing in the game because some emails you need to click on will be drawn outside of the screen.

For now, until somebody comes up with a fix through hacking the game files (if that's possible at all) I would recommend playing at a 4:3 resolution such as 1024x768 or 1280x1024.
avatar
fischkopf: For now, until somebody comes up with a fix through hacking the game files (if that's possible at all) I would recommend playing at a 4:3 resolution such as 1024x768 or 1280x1024.
I agree...on Win10x64, version 1803, build 17110.1000 (latest Insider's)...DGVoodoo2.54 is really quite unacceptable--main character walks through walls, etc.--really unplayable, imo.

What I'm recommending now is 1024x768 with all the driver-applied FSAA & anisotropic you can lay on. Nothing else is really stable, I've found.

The registry fix works--sort of. It won't support resolutions > 1920x1200 (reverts to 640x480 telling me that my frame buffer isn't large enough for 2560x1440 even though I have 8GBs of VRAM), and although it appears to work after a fashion it isn't stable, and the player can expect numerous crashes. Great and valiant try, though...;) Some of these old games are just bugged as they lay...! Judging from my earlier post in this thread years ago I must have at one time achieved at least partial success--maybe. Just can't recall. So I'm sticking with 1024x768 for the time being for this game.

avatar
SpikedSoul: just need to mention this: http://www.wsgf.org/dr/gabriel-knight-3-blood-sacred-blood-damned

1- Open regedit and navigate to HKEY_CURRENT_USER\Software\Sierra On-Line\Gabriel Knight 3\Engine .

2- Edit the decimal value of these keys :
(default) = yyyy
Screen Height = yyyy
Screen Widht = xxxx

Where xxxx is desired width & yyyy is desired height.

(default) and "Screen Height" MUST have the same value.

not sure how well known this solution is...
This does work to a degree...but for me it won't work for anything higher than 1920x1200--and even at that resolution it crashes frequently. Best advice: run at 1024x768 and pour on 8x FSAA and 16xAF--it's the only way to play a reasonably stable game of GK3.
Post edited March 03, 2018 by waltc

Best advice: run at 1024x768 and pour on 8x FSAA and 16xAF--it's the only way to play a reasonably stable game of GK3.
Well, too bad, because framerate is pretty bad without dgvoodoo..(but it has severe graphical glitches)
So in the end i just playing with dgvoodoo 2.55 but without forcing higher resolutions (original 1024x768, 8xMSAA, vsync on, fast memory access on through dgvoodooCpl.exe), performance is much better then without it.