It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hi guys, so I finally managed to get GK3 working at 1080p without any glitches or performance issues using the dgVoodoo wrapper! It now runs just as smooth as you would expect it to run for a game this age. ;)

Unfortunately it does require a DX11 GPU, so anyone with an older PC will not be able to use it.

Here are some screenshots (click to view full resolution): https://postimg.org/gallery/ob0ul67i/b2ca3a48/

I highly recommend forcing 16x anisotropic filtering for GK3.exe in your driver's settings, because it makes textures look SO much better when looking at them from narrow angles. Here is the fix: http://www76.zippyshare.com/v/3QHG6S38/file.html

I tested this on Windows 8.1 with a GTX 970 please let me know if you have any problems.

- - - - - - - - - - - - - - - - -
For DirectX 10 graphics card owners

avatar
fischkopf: I have now found a 1080p solution for older graphic DirectX 10 cards as well: http://www42.zippyshare.com/v/kfkasQUh/file.html

Get DxWnd, unzip to in a separate folder. Apply the regfix from my archive. Now open DxWnd as admin (this is important, otherwise it won't save the profile, next time you open it) go to File / Import and import the GK3 profile from the archive. Now you need to change the file paths, because the profile uses my paths. Right click on the profile and go to "modify". Change the paths so they match yours in the "launch" line, add this after the .exe (without quotes):

" -width 1920 -height 1080"

Now you can play GK3 in 1080p with your DirectX 10 graphics card.

This has a few downsides compared to the DirectX 11 method:

You need to run DxWnd everytime you want to run the game (no big deal I think)
ReShade doesn't work (you can force AA and Anisotropic filtering in your drivers anyway)
The mouse will leave trails in 2D menus (map screen, main menu, inventory, Sidney)

I wasn't able to fix the mouse trails, but I think this is still much better than playing the game in a much lower resolution. :)
Post edited November 14, 2016 by fischkopf
avatar
fischkopf: Hi guys, so I finally managed to get GK3 working at 1080p without any glitches or performance issues using the dgVoodoo wrapper! It now runs just as smooth as you would expect it to run for a game this age. ;)

Unfortunately it does require a DX11 GPU, so anyone with an older PC will not be able to use it.

Here are some screenshots (click to view full resolution): https://postimg.org/gallery/ob0ul67i/b2ca3a48/

I highly recommend forcing 16x anisotropic filtering for GK3.exe in your driver's settings, because it makes textures look SO much better when looking at them from narrow angles. Here is the fix: http://www100.zippyshare.com/v/FNbebv9K/file.html

I tested this on Windows 8.1 with a GTX 970 please let me know if you have any problems.
Good Job...! Works great in Win10x64 build 14271, with an AMD R9 380 4GB GPU! Crimson 16.2's.

This would be my choice for the definitive graphics fix for the game...very nice! Runs fine @ 1920x1200, too!
Post edited March 04, 2016 by waltc
Unfortunately this isn't working for me. Running it on a laptop and using the laptop's geforce 940m card, the game launches in some very small resolution and freezes on a white screen. Launching with the integrated intel card, the game gets to the menu fine in full 1080p but understandably goes black when I actually try to play the game.
avatar
steve2828: Unfortunately this isn't working for me. Running it on a laptop and using the laptop's geforce 940m card, the game launches in some very small resolution and freezes on a white screen. Launching with the integrated intel card, the game gets to the menu fine in full 1080p but understandably goes black when I actually try to play the game.
Yes, from what I can gather the 940m supports only the DX 11_0 feature level, which probably isn't enough to properly support dgvideo...(probably need 11.1 in hardware for that to run properly.)
avatar
fischkopf: Hi guys, so I finally managed to get GK3 working at 1080p without any glitches or performance issues using the dgVoodoo wrapper! It now runs just as smooth as you would expect it to run for a game this age. ;)

Unfortunately it does require a DX11 GPU, so anyone with an older PC will not be able to use it.

Here are some screenshots (click to view full resolution): https://postimg.org/gallery/ob0ul67i/b2ca3a48/

I highly recommend forcing 16x anisotropic filtering for GK3.exe in your driver's settings, because it makes textures look SO much better when looking at them from narrow angles. Here is the fix: http://www100.zippyshare.com/v/FNbebv9K/file.html

I tested this on Windows 8.1 with a GTX 970 please let me know if you have any problems.
Fischkopf you made my day, I was searching for this kind of fix for some time before having the idea of coming here on GOG forum... Thanks to you I will be able to play that game, THANKS !!
Great, thanx!

But is there a way to remove the dgVoodoo logo? It's a kind of annoying.
avatar
jimmytturtle: Great, thanx!

But is there a way to remove the dgVoodoo logo? It's a kind of annoying.
Yup would love that.
Found it! Download fischkopf's fix, unzip it in the game directory.

Then manually download vgvoodo, unzip in the game folder. Click on add, select GK3 directory, then on the third tab, uncheck show voodoo watermark. Apply. Then go in the MS folder, move all of the dlls from this folder into the game folder.

There you go, enjoy GK3!
avatar
jimmytturtle: Great, thanx!

But is there a way to remove the dgVoodoo logo? It's a kind of annoying.
avatar
Dr.Brocoli: Found it! Download fischkopf's fix, unzip it in the game directory.

Then manually download vgvoodo, unzip in the game folder. Click on add, select GK3 directory, then on the third tab, uncheck show voodoo watermark. Apply. Then go in the MS folder, move all of the dlls from this folder into the game folder.

There you go, enjoy GK3!
I will update the fix to have no watermark by default then, if it annoys the majority of people.

edit: done, now includes launcher as well for convenience.
Post edited April 18, 2016 by fischkopf
avatar
jimmytturtle: Great, thanx!

But is there a way to remove the dgVoodoo logo? It's a kind of annoying.
avatar
fischkopf:
avatar
Dr.Brocoli: Found it! Download fischkopf's fix, unzip it in the game directory.

Then manually download vgvoodo, unzip in the game folder. Click on add, select GK3 directory, then on the third tab, uncheck show voodoo watermark. Apply. Then go in the MS folder, move all of the dlls from this folder into the game folder.

There you go, enjoy GK3!
avatar
fischkopf: I will update the fix to have no watermark by default then, if it annoys the majority of people.

edit: done, now includes launcher as well for convenience.
Thanx!
Wow, fischkopf, thanks, you're a lifesaver!

I'm using Windows 10 and I was really struggling to get to play this, getting stuttering, freezes, and crashes, no matter what I did with compatibility modes. Was going to just give up. Your file made everything run real smooth, and it looks better too!
avatar
MrMarbles77: Wow, fischkopf, thanks, you're a lifesaver!

I'm using Windows 10 and I was really struggling to get to play this, getting stuttering, freezes, and crashes, no matter what I did with compatibility modes. Was going to just give up. Your file made everything run real smooth, and it looks better too!
You're welcome, I think the GOG team should consider including DGvoodoo by default. ;)
Thank you for the great work. I'm excited.
I have now found a 1080p solution for older graphic DirectX 10 cards as well: http://www42.zippyshare.com/v/kfkasQUh/file.html

Get DxWnd, unzip to in a separate folder. Apply the regfix from my archive. Now open DxWnd as admin (this is important, otherwise it won't save the profile, next time you open it) go to File / Import and import the GK3 profile from the archive. Now you need to change the file paths, because the profile uses my paths. Right click on the profile and go to "modify". Change the paths so they match yours in the "launch" line, add this after the .exe (without quotes):

" -width 1920 -height 1080"

Now you can play GK3 in 1080p with your DirectX 10 graphics card.

This has a few downsides compared to the DirectX 11 method:

You need to run DxWnd everytime you want to run the game (no big deal I think)
ReShade doesn't work (you can force AA and Anisotropic filtering in your drivers anyway)
The mouse will leave trails in 2D menus (map screen, main menu, inventory, Sidney)

I wasn't able to fix the mouse trails, but I think this is still much better than playing the game in a much lower resolution. :)
for DX11 cards method: He doesnt works

The only thing that starts is a black screen with at the top left the "ReShade loading files" logo ... but nothing is ever loaded.

I tried with Windows 98 compatibility mode and so the game starts, but at 10fps

The registry key fix does nothing, whether you put it or not

This fix It's all a scam.

Windows 10, gtx 1070