It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

geminidomino: I'm not showing any patch on my shelf?

Update: Derp. Nevermind. This is for the remake. Brainfart.
JudasIscariot: If you are on a Mac, we haven't released an update for the Mac version.
Having issues with giving detective Mosley the evidence to reopen the case on day 5. According to other forums, it was fixed in the October patch. This game is almost one year old and still no patch on the mac?
I just did that part today.

Did you give everything needed to trigger that part?
retsushi: I just did that part today.

Did you give everything needed to trigger that part?
Yeah its a known glitch.
Fortunatley, I found a old tread with a link to a save game taken right after this scene, so I'm ok for now

old thread:
Still no mac patch in sight...?
kicker04: Still no mac patch in sight...?
Sure there is: it's called Bootcamp...;)

Apple's now supporting Windows 10 with Bootcamp--never wait on a game patch again! 2nd-class citizens of the gameverse no longer...! Carpe Bootcamp...!
Hopefully GOG can get around to deleting those reviews that contain spoilers for later in the game, who the hell does that in a review? Especially one that revolves around characters and story like an adventure game?
kicker04: There is always the same error message: "Game installation not found, please reinstall."

Is there maybe another patch that must be installed previously?
Same here. No solution?
I own the game, but I cannot download it via Galaxy ... okay, try it via browser now...
Post edited December 17, 2020 by Schlaumayr