It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I've just tried to reinstall the Linux version of FTL, and despite the only available download language being English, the current download from the GOG website, 1.6.12 (2) is installing an Italian language version of the game, with no visible way of changing the language to English. Am I missing something really obvious?
No posts in this topic were marked as the solution yet. If you can help, add your reply
Well, I found the solution in case anyone else has the same problem.
I needed to go edit ~/.local/share/FasterThanLight/ and edit settings.ini, changing the line language=it to language=en
Still not quite sure why it installed with Italian as the default though...