It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

penyuan: Hello,

I installed the Linux version of Fragile Allegiance and it starts fine with cutscenes and it reaches the main menu. I can start a new game, but as soon as I click on the asteroid view button the game crashes.... How do I troubleshoot this? Thanks!
Hello penyuan!

It would be very helpful if you could deliver more details about your issue:

- the entire terminal output, after you start the game (just what appears in terminal after starting the game using script)
- your detailed system report that can be generated using the script that you will find in the game installation path

What Linux distribution do you use? Is it 64 bit? If yes, could you try running the game using 32 bit DOSBox instead? You need to install its dependencies first (instructions for Ubuntu):

sudo apt-get install libasound2:i386 libc6:i386 libgcc1:i386 libpng12-0:i386 libsdl-net1.2:i386 libsdl-sound1.2:i386 libsdl1.2debian:i386 libstdc++6:i386 libx11-6:i386 zlib1g:i386

Then in the game folder:

./dosbox/dosbox_i686 -conf "dosbox_wwheels.conf" -conf "dosbox_wwheels_single.conf"

Looking forward to your answer :)
Post edited November 29, 2017 by linuxvangog
penyuan: Thanks for your quick response. I'm running a fully updated Manjaro Linux installation, and it is indeed 64-bit. Here is the terminal output:

Running Fragile Allegiance
Starting DOSBox
DOSBox version 0.74
Copyright 2002-2010 DOSBox Team, published under GNU GPL.
CONFIG:Loading primary settings from config file dosboxFR.conf
CONFIG:Loading additional settings from config file dosboxFR_single.conf
MIXER:Got different values from SDL: freq 44100, blocksize 2048
ALSA:Can't subscribe to MIDI port (65:0) nor (17:0)
MIDI:Opened device:none
DOSBox switched to max cycles, because of the setting: cycles=auto. If the game runs too fast try a fixed cycles amount in DOSBox's options.
./dosbox/dosbox: line 14: 3005 Segmentation fault (core dumped) "${CURRENT_DIR}/dosbox_x86_64" "$@"
penyuan: And I've uploaded the system report to here:

And here:

If you can let me know how to run 32-bit DosBox on an Arch-based distribution I'll give that a try, too. Thanks!
Have you tried running the game using the "dosbox" command I posted above? It will run the game using 32 bit DOSBox which is included in the game package.
Post edited November 30, 2017 by linuxvangog
penyuan: I just tried it, and the only thing I got was this:

./dosbox/dosbox_i686: error while loading shared libraries: cannot open shared object file: No such file or directory
penyuan: The strange thing is, I see the file and in [game directory]/dosbox/libs/i686.....
They cannot be found by linker, the launch script usually sets the library path but we are doing some debugging here :)

How about:

export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:./dosbox/libs/i686"
./dosbox/dosbox_i686 -conf "dosbox_wwheels.conf" -conf "dosbox_wwheels_single.conf"
penyuan: Thank you @linuxvangog! I tried it and here's my result:

1. After setting the library path, I got a new error like this:

./dosbox/dosbox_i686: error while loading shared libraries: cannot open shared object file: No such file or directory
penyuan: 2. However, I discovered that I have in my /usr/lib32/, so I created a symlink to it inside ./dosbox/libs/i686 and I was to start dosbox_i686.

3. Once inside DosBox, I ran the following commands to start the game:

mount C "data"
imgmount d "data/FRAGILE.DAT" -t iso
penyuan: 4. This time I was able to start a new game and get to the asteroid view *with no crashes*. I didn't play for long but the game appears to be working correctly!!

Does this mean that this is a 32 vs 64-bit problem? If so, how do I resolve this in a more permanent way? Thanks!
It certainly looks like an issue with 64 bit DOSbox. Unfortunately, it happens randomly and sometimes we're not able to catch it during our QA process.

To always use 32 bit version of DOSBox when starting the game, edit the "dosbox" script inside the "dosbox" directory and change the line 4:

declare -r ARCH=`uname -m`


declare -r ARCH="i686"