It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
If you were like me and could only run this game in windowed mode, because if you tried to run it in fullscreen, the game would just be almost unplayable due to screen tearing, and not updating the screen fast enough when moving resulting in choppy gameplay and a very unenjoyable experience overall, then you only need to change 1 option to make everything run smooth as silk.

Go to your installation folder and locate the file "DOSBox Configuration". Launch it and you'll find that Graphic mode is set to "Surface" which is the whole thing causing problems. Simply select "DDraw" and save the settings. That's it, next time you start up your game it should run perfectly in full screen.

(Thanks to Abelar for pointing out the solution)