It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

This is what I did:

1. Created a party of four fighters and fighter multiclassers as well as two clerics
2. Gave all of the party's gold to the clerics.
3. Went to Training Hall and removed the four fighter-type characters from party
4. Went to the weapons and general goods shops to equip the clerics
5. Went back to Training Hall, re-added the four fighter types, traded the clerics' remaining platinum to them, and removed the clerics from party.
6. Went to the weapons shop and tried to have one fighter buy some banded mail from non-pooled funds.

This was the overflow bug that arose from pressing "b" for Buy:

1. Platinum, gold, silver, and copper changed into the millions or some other odd number.
2. Encumbrance was also in the millions. Movement was in the thousands.
3. Equipment list showed millions of some random pole-arm, already Joined although such weapons don't Join into stacks in the equipment list.
4. On the character page, where it indicates status (usually "Okay") there was a full edge-to-edge horizontal line of garbled non-alphabetic characters including many solid green boxes where a character could not be displayed.

I was partly able to reproduce this problem: from a saved game of the same party I couldn't as the previously removed characters had been added, but did create a new party that reproduced the problem as above.

Anyone know what even happened there?
Did you have enough money to purchase the item you tried to purchase?

If not, was there, at some point, a character in that slot who *did* have enough money?

(This bug sounds more like an underflow rather than an overflow. Also, it sounds lkike there's some memory corruption going on.)

As for the results you report:
1 is what I'd expect in the case of a currency underflow.
2 is expected if money has weight. The high movement rate is either another underflow or a display error. Have you tried using the character in battle, and if so, can the character actually move that many squares (or at least as many as is possible in the engine)?
3 and 4 sound like memory corruption; for 4 the byte that stores the character's condition must have somehow been set to a value that the game doesn't know how to understand, so it accesses past the end of the array. (Reminds me of when I used a hex editor to set a character's gender to "COPPER".)

Maybe do more experiements and report the results?