It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Running the Mac version of Fallout 2 with the SFall >= 2.16 returns an error stating:

Fallout appears to be running in compatibility mode. (see screenshot for full message since GOG forums won't allow the text for some reason)

Clicking 'OK' closes Fallout 2. I've tried the regedit trick where you remove the 256COLORS reg to no avail.

Unfortunately, this also means the next version of RP will not work since it ships with SFall 2.20. I am not aware if it is safe to downgrade SFall while using the soon-to-be-finished RP beta, but it would be great to have a heads up on the problem before it is officially released.

Thanks for any help!
Post edited February 10, 2013 by kybishop
No posts in this topic were marked as the solution yet. If you can help, add your reply
Problem solved!

SFall 2.16 and up check two reg locations:

HKEY_LOCAL_MACHINE\\Software\\Microsoft\\Windows NT\\CurrentVersion\\AppCompatFlags\\Layers
HKEY_CURRENT_USER\\Software\\Microsoft\\Windows NT\\CurrentVersion\\AppCompatFlags\\Layers

so make sure you delete the 256 colors reg in both!
I know this post is almost 3 years old but i am having issues with the solution you posted, i deleted both of the 256 colors reg and now when i open fallout 2 i get an error saying
"The instruction at 1004975b referenced memory at 00000000
The memory could not be read from"

if anyone knows of any solution to this please let me know