It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Not from a technical standpoint, as some of you may have interpreted that, but from a gameplay point of view. I made a character with a really high Barter skill as I was going to play as a non-thief for once. I went to rescue Smiley from the gecko caves, almost instantly got radiation poisoning, pressed ahead anyway, got Smiley back home but then lost 4 AP, 4 Strength and 4 Perception (presumably from radiation poisoning), went to The Den to try and buy some Radaway only to find that it cost about 850 caps, even with my Barter skill of ~80%. I checked out how Barter works in the Fallout Wikia and it said "Barter is incredibly important, if it's at a very low level, Radaway can cost as much as 700 caps". Thanks, Restoration mod!

I tried to make a run for it to Vault City as it's the one place I could remember with a doctor, but got attacked almost every grid square and got killed pretty quick as my character is more of a speech-based one. When I cluelessly played Fallout 2 several times as a teenager, I had no problem with it at all. Now it seems like beating my head against a brick wall.
Did you have the rubber boots? You can find them in trapper town in a locker. You have to talk to a NPC in a building to get his key to kill Keen Rat (God rat or w/e). Theres 2 pairs in Klamath and another pair in the toxic caves. Oh and you can kill Tubby and the other merchant for no karma loss. I remember killing both and one of them had 3 radaway in they're invantory.

Quest guide:
I have two pairs of rubber boots on me and I still got radiated as soon as I entered the cave. I think this may be one of the many things the Restoration mod changed to make the game harder. Random encounters also seem incredibly hard. I got ambushed recently and in the first turn, before my turn came up, two party members were killed.
Played FO2 with restoration about a year ago, and gecko cave was a bit tough. Hard to avoid the green sludge with all those geckos patrolling about... I think there was also radaway or rad-x to be found at the cave. Something there like that there certainly was because I didn't need anything extra to get away.

Doesn't mean it wasn't changed in later patches though.
I didn't have that hard of a time with the toxic cave just the geckos where asshats. Plus golden geckos will radiate you once it bites (I think).
I started playing the mod today and yeah, it's definitely a tougher game. It seems the encounter rate is higher, Sulik starts out a bit weaker and I think there's less stuff to steal from people as well.
I didn't have much of a problem with Radiation, but I recommend doing all quests in Klamath before buying Radaway so that you can get a discount on it, and the Fast Shot trait really helps early on. Other than that just try to kill what you can before going from the Den to Vault City because the slavers on the way love using burst with SMG:s. That's where I'm at and I've died a few times for not being cautious enough. Remember that there's no need to rush in Fallout 2.

If it's okay to borrow the topic, did anyone have problems with the brahmin rustling quest? I've pretty much solved it, but the Buckner woman says I should talk to "mom" about it. Who is she talking about here? After talking to everyone and even going to "Mom" in the Den I just went on with the game and I'm thinking it must be a bug.
Leever, you was talking to Maida Buckner. Maida was talking about her mother Ardin Buckner ( the other lady inside the building with Sulik ). It isn't a glitch.

1. Maida Buncker
2. Ardin Buckner

Both are inside the same building.

Oh and they may give you the run around. Talk to daughter, talk to mother ect. ect.
Post edited March 01, 2011 by Unholyfurball
I could swear I talked to both a few times, but Ardin just talked about Smiley (I rescued him with the other quest active) and the dialogue option didn't come up. Maybe I had to reenter the map. Well that solves that, thanks.
Post edited March 02, 2011 by ResidentLeever