}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
(Note: On Intel Integrated graphics, used d3dx9.dll work around)

Any time when I attempt to launch FO3 through the GOG Galaxy Client, it will always crash before it even gets to the main menu. Basically, as soon as the FO3 team starts playing on the main menu, it crashes. I've bypassed this by launching FO3 directly by going through both the launcher and base executable in the files. However, I feel this ties in to my second issue.

I can't seem to get any of the DLC to load in. When I first launched the game through the executable and doing a little test run/playthrough to make sure it was truly working, I was never shown the "Downloads" option in the main menu. After closing and re-launching the game (this time through the FO3 launcher executable, not just the main game), the DLCs still never loaded, but the "Downloads" option was there, just greyed out. I've also made sure that the DLCs are indeed loaded by making sure they are checked off on the Data Files option on the launcher.
No posts in this topic were marked as the solution yet. If you can help, add your reply
Bump for visability + uninstalling and reinstalling still has fixed nothing. In addition, without the d3dx9.dll fix, I was able to launch the game and get into the menu just fine, just an issue of crash on play. Any attempt to launch it through the option on GOG Galaxy causes the crash on start up, while, again, any attempt launching it through the FO3 launcher or game executable in the game files launches the game perfectly fine with no crashes on start up, creating or loading a game, or after any amount of playtime (little over 2 hours to test)

EDIT: After an unknown amount of time, DLCs have started loading it. Point Lookout and The Pitt (in that order) have just popped up their starting notifications, Mothership Zeta, Broken Steel, and Op: Anchroage (again, in that order) slowly popped up after. However, the first issue of crash on start up without launching the launcher or game executable directly still persist.

Whats odd about this is that the DLCs did not load up even after the time I gave on the same save. In some cases, it may have been close to the time it took for the first DLC notification to pop up.
Post edited January 19, 2018 by Randomman96
what works for me is to use windows 7 or 8, and I with Gog's fixed up game of Fallout 3, I should not have to worry about crashes. Don't use windows 10, and don't use Labtops. Also, don't start game or launch it ever (as with most Gog games) without using the official downloaded Gog game launcher. You don't need Galaxy. Just download the file normally and launch. Now I am not sure, but the reviews of players say, that they could use the game and the missing dx file didn't pop up. I don't know what type of computer you are using and I don't know its power or performance. What I do know is that there are plenty of people out there with the Gog game of FAll 3 and it doesn't crash and works fine. Use your common sense. You sound like you know about computers. Start the game using the most basic normal approaches. Labtop and windows 10 are not normally how one plays old games. Its not you, its windows 10. That damn stupid software is too advanced for most games and is unnecessary. Plenty of good small businesses and big companies STILL use windows 8, at most. Sorry I could not help you more. But at least you got part of the game to work. I am going to order the game soon and start playing and will let you know if I run into trouble.

I have a windows PC Windows 7 with a 2 gig graphics card and 8 gigs of ram, and a Quad core. Without God, it would not work. But according to other Gog game players, the game works now with Quad core and faster computers. Hang in there, man.