It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


i'm currently stuck with the Fragment of Earth.

Way before the events with the fragments i bought the key to his house in the Future and also visited him in the past (before the weapon exploded) and talked to him (he throws you out and FIna says that he might be out of his mind)

now i'm searching the earth Fragment and i SHOULD be able to talk to him (or at least a cutscene should play) but nope... still the same result.

Is this a bug or did i miss something??
Late answer (maybe you already solved this), but this comes to my mind:

- visit Ruins of Demonia in the Present and talk to everyone there.
- older Dalkin lives in his house in the Present. Talk to him and get the Imperial Medal from his closet. Now go to Demon Island in the Past, meet younger Dalkin and give the medal to him.
Post edited August 04, 2016 by JamesBond007