It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Can't even get into the game :(

The title appears, the menu appears, my mouse flashes on screen for a second, then disappears.

If I press enter, it takes me onto New Game, but I can't get down to options. Tried typing, using the arrow keys... it's just not working for me.

Anyone else?

Well would you look at that... solved my own problem.

I had a G27 Steering wheel plugged in. For some reason it caused issues with the game, hiding the mouse.
Post edited September 15, 2016 by 4demon
No posts in this topic were marked as the solution yet. If you can help, add your reply
The mouse issues are annoying but you can get past them and into the game by using ALT-TAB to switch out of the game and back again. Also, try and keep the mouse pointer near the lower right during the intro to keep it visible.

The pointer issue did not inhibit my playthrough of the game once I docked.
I have exactly the same issue. I know the devs pushed an update for Steam just to this problem. Can GoG confirm they got the patch already?
Ok, I found that i left my saitek rudder pedals connected. You must disconnect everything (gamepads, joystick, any controller device) to make it work. Is a known problem with unity, hope developers fix it, because is highly inconvinient having to unplug everything.