It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hey all, I was having the same problem everyone seems to be having trying to run this on W10, namely an error box coming up and saying "there is a problem with your media device. Make sure it is working correctly o". This seems to occur every time a video or music track attempts to play.

Using the program DxWnd, we are able to add additional compatibility options to this game.

1) In DxWnd: Edit > Add > MAIN > Path: Navigate to PLAGUE.EXE. (Should look like G:\GoG Galaxy\Entomorph\plague.exe).

2) On "Main > Generic" activate "Acquire Admin Caps", the program will restart when you try to run this to get Admin privs.

3) Now to the good stuff, click the "Sound" tab at the top. Check em all that doesn't mute your sound. I checked: Safe midi, Hook ear sound dll, Hook DirectSound, Lock CD Tray, Virtual CD audio, Ignore Device Id., Force CDROM present, Hack Track Frames, Emulate CD pause capability, Fix default MCI Id. Now I'm not sure which one actually fixes the issue. I tried most of these individually, and I'm not going to look a gift horse in the mouth, but let me know if you find out exactly which one is causing the error message here.

4(May be optional)) Compat. Tab, Set single core process affinity, Limit Available Resources, Fake Version checked: Windows 95, Bypass GOG libs.

I now have full video and soundtrack in the game. Let me know if you narrow down exactly what the issue is here, but for now this should get you in with full functionality.
DxWnd helped me too with sound, but had to do a couple more things.
Didn't see Sound tab at first so went to Options and set to Expert mode.
Had problem with mouse. It was a bit off. Went to Edit->Modify and in Main tab set from X,Y coordinates to Desktop.
Tried with the settings given. How do you deal with the infamous MCI-CD Audio error?
Hey, thanks for this! This solution worked for me, and now the game plays CD and cutscene audio properly.
VR48: Tried with the settings given. How do you deal with the infamous MCI-CD Audio error?
I know this post is a year old, but I still get this error, too. Clicking "Retry" launches the game without issue for me. I am using the latest version of dxwnd as of this post, so that may be the trick.