It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera


After years being unable to play my physical copy of EE CoHokum I finally decided to get it on GOG, in which I heard it was fixed/made compatible for Win7 and so on.

I have started up the game eager to start and, despite the changes, most things are familiar as they used to be.
I only have a major problem with take-offs and landings, in which the helis simply bounce around the landscape or acelerate at insane speeds on the ground, specially while the rotor is stopped!

Take-offs are somewhat manageable, I just need to wait until the heli stops bouncing in some kind of seizure-fashion... problem is with landings. I managed to do a couple landings as I used to do in the old game, but if I do not rush to leave the heli immediately, it may suddendly decide to bounce off the ground or accelerate at some insane speeds (over 300) in just a couple seconds after I landed and the rotor stopped.

Is there any fix for this or config that I can touch to resolve the problem? I remember that in the old versions, the helis usually kinda "sticked" to the ground once you would touch down with all wheels (as long as the wheel brakes were on)

On the other side, an optional question, that could help me as well:
I was extremely used to the old flight HUD (at least, in my version, it would switch to a more detailed flight mode whenever weapons were offline). I noticed this is not happening in this version, this is not critical as I can mostly fly by-eye, but I do remember the detailed piloting HUD came quite handy while flying during nights.

(See attachments, they used to look similar to that)

EDIT: Found out about the HUD, Shift+O does the trick.
Also, found out about the community mod/improvement patch. Installing it slightly mitigated the problem, the helis do not bounce anymore, but they keep sliding/rotating and dancing around while landed, even with rotor off... This is actually causing me to lose the tail rotor before I can even consider take off. Please let me know if you have knowledge about how to fix this issue.

Post edited December 23, 2017 by Saberuneko
No posts in this topic were marked as the solution yet. If you can help, add your reply
same problem.
no solution.

GOG support has helped me on resolving this issue!
Process may vary depending on the system. In my case I followed this advice:

1.- Force V-Sync in the game (in my case it was done through a RADEON settings panel)
2.- Run game as Administrator
3.- Find the game process (cohokum.exe) and change affinity to CPU0 only.

Wow, it really looks like forcing V-Sync On fixed the problem!
I just did a short test flight, so may be its just coincidence, but the bouncing was gone.

Post edited February 12, 2018 by MikeWerner
I don't have that issue during take-off, but if you land someplace other than at base, or on an uneven surface then it will start bugging out. Try to land level, and don't let you tail rotor hit the ground first, as it may cause those issues, and damage you helicopter at the same time. And no, setting torque to 0, engaging the wheel brakes, and shutting off the engine doesn't fix the issue once it starts it's happy dance.
Disregard this post. See below post for workaround.
Post edited November 30, 2019 by mrelusive603
Saberuneko: This is actually causing me to lose the tail rotor before I can even consider take off. Please let me know if you have knowledge about how to fix this issue.
I tried reverting to an earlier version of the mod pack (v1.15.2FIX5) but that also has the spinning bug. In fact, user Perscienter mentioned this bug way back in 2012, so it's clearly been an issue for some time. There hasn't been an update to the mod pack since 2016 so I doubt there will be a fix.

As a workaround, I just use the repair cheat by pressing CTRL+R until you're airborne. It's not realistic but it works for me.

Make sure you have cheats_on=1 set in your EECH.INI otherwise it won't work. It should be set by default if you use the mod pack, but never hurts to check anyone.

Hope this helps!