It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

How can I change subtitles? I have english subtitles but I need spanish ones.

I dont find option for change it :S
Go to "...\ELEX\data\ini", open the "ConfigDefaultNew.xml" and the "ConfigDefault.xml", search for the word "Language" and edit the entry "SubtitleLanguage".
Post edited October 18, 2017 by pcblizzard