It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Allandor: I restartet the whole game now and it seems that did the trick (maybe in combination with the new update). But I really hope this bug does not occure again.
kamikazeTMX: well have fun playing the game :P
It now crashed again (and over and over again) after 6h. It's a great game, but it seems there is a really strange bug with the RX570.
In the official Elex forum are also many users with an RX570 that have the exact same problem.
Windows 10 Pro here just little over 10 hours and not one crash or frezze.
Have not that much time, but tried Elex with the newest 17.10.2 driver from AMD and it didn't crash for a while.
Will try it again tonight.

No still crashes (made a short second test)
Post edited October 24, 2017 by Allandor
Well, there it is again. Game is crashing again and again, even with the latest patch.
Seems like I reached again a point in the game where something is calculated in background.
It is still not fixed, but at least someone found another workarround.

When the game has loaded, teleport as fast as you can (before it crashs again) to Ignadon. This seems to be a relative "crashfree" zone.
At least I could play a little bit more that way, the problem is leaving ignadon (and surroundings) lead to a crash at some point.
I have the AMD Vega 64 and had one crash in the entire game, but that was constant after the video scene where the generator is destroyed with the Glider. I can see the whole sequence and when the glider is in front of that fence on the ground -> application stopped working all the time.

I could skip the scene at that point and continue playing, though.
I'm having repeated freezing requiring a hard shut down. Game plays perfectly for a few hours, then a freeze. I've updated all my drivers, but that didn;t help. This seems to be specifically a problem I have with PB games because everything else plays like silk.
Post edited November 19, 2017 by Loralou
And the problem is still there, the official forum was also shut down, so I guess the game has no official support anymore?

I still want to play that game, but I need a patch so I can play it. My GPU (RX570) is also rockstable in all other titles and in world of elex forum the first PS4 Pro owner seems to have the same issue.

according to gog.galaxy I already played it for >30 hours, but a big chunk of that time were the first 9h, than I restarted from scratch because of the crashes and it worked again for about 9h but than the crashes occured again and many many hours were just trying to get the game runnig.
Post edited April 17, 2018 by Allandor
The Elex forum on Steam is quite active, you might find some info or help there, as crashes have been widely discussed.