It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
For some reason whenever I try to run OBSE, it tells me I have an unknown version of oblivion. anyone know why or how I can fix this?

Edit: I solved it. I downloaded the gog launcher and it wouldnt work, and then I realized it's because the unnoficial patch didn't install but all the other mods did, so it was causing it to crash.
Post edited June 03, 2017 by SmashedPotatoes
You need to download the latest loader from OBSE's site, http://obse.silverlock.org/ and overwrite the obse_loader.exe you already have in the game folder. Second link from the top, immediately below what you already downloaded.

The thread discussing it: https://www.gog.com/forum/elder_scrolls_series/oblivion_psa_obse_doesnt_work_with_this_version_yet
Post edited June 03, 2017 by pbnjoe
avatar
pbnjoe: You need to download the latest loader from OBSE's site, http://obse.silverlock.org/ and overwrite the obse_loader.exe you already have in the game folder. Second link from the top, immediately below what you already downloaded.

The thread discussing it: https://www.gog.com/forum/elder_scrolls_series/oblivion_psa_obse_doesnt_work_with_this_version_yet
even after downloading that, all I get is a quick black screen and then back to the desktop... I'm pretty sure I'm putting all the files in the right location(everything in the oblivion folder) any ideas?
So you extracted obse_0021.zip into Oblivion's folder, so you have obse_loader.exe and OBSE's DLLs and everything alongside Oblivion.exe and you mixed the Data folders (so it has obse.ini in Data/OBSE/, and then you took the file from obse_loader.zip and overwrote the first obse_loader.exe, and then ran it?

If so, I'm not sure what's up. I'd redo it just in case.

Do you happen to be playing the game on integrated graphics? Not sure that would make anything different but that seems to mess things up in the gaming world often.

P.S. obse_steam_loader.dll is unneeded.
Post edited June 03, 2017 by pbnjoe
avatar
SmashedPotatoes: For some reason whenever I try to run OBSE, it tells me I have an unknown version of oblivion. anyone know why or how I can fix this?

Edit: I solved it. I downloaded the gog launcher and it wouldnt work, and then I realized it's because the unnoficial patch didn't install but all the other mods did, so it was causing it to crash.
Have you tested the last OBSE loader ( only the latest loader download) file date 18.05.2017?
After install last Obse Version change the loader with this file?
avatar
SmashedPotatoes: For some reason whenever I try to run OBSE, it tells me I have an unknown version of oblivion. anyone know why or how I can fix this?

Edit: I solved it. I downloaded the gog launcher and it wouldnt work, and then I realized it's because the unnoficial patch didn't install but all the other mods did, so it was causing it to crash.
avatar
Hunkelchen: Have you tested the last OBSE loader ( only the latest loader download) file date 18.05.2017?
After install last Obse Version change the loader with this file?
Yes, it works!
I guess the GOG binary is different from the standard GOTY?
avatar
OldOldGamer: Yes, it works!
I guess the GOG binary is different from the standard GOTY?
Yep, since it doesn't have DRM in it it's different to all the prior releases, and OBSE hashes Oblivion.exe and checks it against a list of hashes baked into itself. If it doesn't match, it refuses to load.
avatar
OldOldGamer: Yes, it works!
I guess the GOG binary is different from the standard GOTY?
avatar
pbnjoe: Yep, since it doesn't have DRM in it it's different to all the prior releases, and OBSE hashes Oblivion.exe and checks it against a list of hashes baked into itself. If it doesn't match, it refuses to load.
And why exactly did OBSE act as a DRM Police?
avatar
pbnjoe: Yep, since it doesn't have DRM in it it's different to all the prior releases, and OBSE hashes Oblivion.exe and checks it against a list of hashes baked into itself. If it doesn't match, it refuses to load.
avatar
marmormurmel: And why exactly did OBSE act as a DRM Police?
Your response made me look back into this, as I had checked into it years ago as I'm big into future-proofing things (as everyone here is I'm sure). They *aren't* DRM police, but they *do* have OBSE not load if it doesn't recognize the exe. However, looking at the source code, it seems to have a pretty extensive checksum list of versions/"releases" of the executable. Basically it seems they only care that you're running the right patch version.

For posterity:

https://github.com/llde/Oblivion-Script-Extender

Specifically the /obse/loader_common/EXEChecksum.cpp file.

So, if there's a new release you have your hands on in 30 years and the devs have fallen off the face of the earth, you can still have your Oblivion and OBSE if you take a copy of that, modify, and compile it :)

Interestingly, I don't see GOG's version on there. They must have just added it locally, compiled, and threw it on their site.
Post edited June 06, 2017 by pbnjoe
:( still not working for me. Getting the unknown oblivion version error on my GoG GOTY edition. What i did: fresh install of the game through gog galaxy; installed the unofficial patch through vortex; downloaded OBSE from the official website and extracted it into my game folder; downloaded the GoG loader from the official OBSE website and dumped it in my game folder overwriting the older version; tried to run the game and got this error.

What am i doing wrong? Seemed pretty straight forward... what am i missing ?

(i have a friend who had the same problem but he found a pirated copy of the gog version with OBSE included and he sais that's the only way to make it work, but this way u don't get could saves and crap from gog galaxy....)

EDIT: I've managed to make it work as follows: Install GOG Galaxy in the DEFAULT LOCATION; download and install oblivion IN THE DEFAULT LOCATION; Run oblivion to generate settings file; (download and install vortex mod manager if not already installed) install oblivion unofficial patch using vortex; Download OBSE latest version from official site and extract it in the game folder; Download OBSE gog launcher and copy it in the game folder and overwrite the other launcher; Set launcher in compatibility mode for windows 7 and run as administrator while adding it to windows defender exceptions list (without doing last 2 steps OBSE launcher launches the game then closes it with no error message attached). All done. Mod your game with vortex and enjoy!
Post edited August 02, 2019 by mannos86