It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I just downloaded Earthworm Jim 1 & 2. I did a basic installation and then tried to launch EWJ 1. My computer's screen went black and I couldn't do anything. I tried "escape" and ctrl + alt + del to get back to normal, but nothing happened. I had to turn my computer off and on to do anything. The same problem happens when I try to launch EWJ 2.
For what it's worth, I also had this problem when I downloaded a freeware game earlier this week, but I just guessed it to be a problem with that game.
I'm running Windows Vista 64 bit.
This question / problem has been solved by Ralackkimage
Just a quick test, change the following sound options from what they are to off basically.
Mainly want to rule out it crashing due to a sound issue. If its not emulating the sound at all and it still crashes it should be a safe bet its not the sound.
I opened it in wordpad and made the changes. Am I supposed to save the document? Because it's denying me access (and I'm on the administrator account).
TAG123: I opened it in wordpad and made the changes. Am I supposed to save the document? Because it's denying me access (and I'm on the administrator account).

If you installed earthworm jim to program files, uninstall it completely and reinstall to something like C:\games\earthworm jim. See if the game will run without messing with the config after doing that.
If not then try changing the sound options again and this time it should allow you to save.
Much closer now!
I uninstalled it, like you said, and reinstalled it into the documents folder. Before I did this I turned off my firewall, just in case that was the problem (I didn't think so). I launched the game just to see if it'd run and it did!
I figured it was a firewall problem, so I tried to install it again under my programs, like before, but with the firewall off. It still doesn't work. So I installed it again under my documents.
There's still some problems, though. I can only run it if I click on the shortcut it installed on my desktop. If I instead go the file location and run the application, it says it's incompatible with 64 bit. Odd.
This is also keeps me from seeing a few bonus things that I can only open from the file location (Toy Show and the tv show intro. Both use DOS Box to run).
Well the shortcut actually runs the program through the earthworm jim config file to make it compatible. Try right clicking the application in the folder and running it under compatibility mode now its no longer in program files.
Vista seems to be very protective of programs installed under program files and won't allow things to be changed easily, this causes alot of problems with games.
The other option is to find the toy show and tv show intro on youtube or something and just watch those there.
Thanks for the help. I'm at least able to get the game running, so I'll go ahead and mark this as a solution.