It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
We are currently gathering more information about the black screen glitch on ATI graphics cards. The game runs stable on all machines and all operating systems (Windows 7 included) when hardware acceleration is disabled and on 800x600 resolution - 1024x768 may be unstable on some machines.

Until we can come up with a permanent solution, ATI users should use this workaround. You need to extract it and launch the dk2_safemode.exe file from anywhere. It will also enable bilinear filtering and make software mode look a lot better.

Please send us a tech support ticket with a DXDiag.txt file if you're encountering this or any other issue, especially if you're getting the black screen glitch on NVidia graphics (still unconfirmed). It will help us investigate this issue further.

We sincerely apologize for the inconvenience and will keep you updated about our progress in this thread.
Post edited August 26, 2011 by Firek
Fantastic thank you. I knew you wouldn't let us down GOG!
Hardware accleration as in "the checkbox in the game" or do I have to fiddle with dx/gfxdriver before I start the game?
I am running a i7 and a NVidia 580 in 7 64 Pro, the game seems stable, however I get flickering, pretty bad in the menu, but not nearly as much in the game. Has this been seen/fixed/etc yet?
The problem is very likely caused by lacking z-buffer support (or it's very different nowdays) in modern graphics cards. Apparently ATI doesn't support legacy games :(

EDIT: I tested with my laptop, which does have NVIDIA ION, hardware acceleration works when camera is set to oblique by pressing F3, otherwise it's black unless zoomed in. This also proves that the problem lies in the z-buffering.
Post edited August 26, 2011 by oudai
THe fix also appears to work if you have the CD ROM version of the game. Result!

As a matter of interest the flickering also occurs on intel mobile chipsets (IGMA) - Mobile Intel 945.
After several hours of play i can tell this workaround safemode exe works quite well playing in 800x600, but seems to me the same playing the normal exe in 800x600, at least i dont see differences about crashing.
The game still crashes every 2-3 hours of play, which seems acceptable to me to play it.
The safemode anyway does not permit anymore to change brightness in the graphic options.

Still for some reason the game keeps saved custom keymapping only to a degree, which is weird, some keys remain saved, others needs to be remapped at every game start.
(in example it keeps saved wasd intead of arrows, but other keys are resetted to default every game start).

Running on vista 32 - Intel E8500 (dual core duo 3.2), 3gb ram, ATI 5770 1gb.
avatar
oudai: The problem is very likely caused by lacking z-buffer support (or it's very different nowdays) in modern graphics cards. Apparently ATI doesn't support legacy games :(

EDIT: I tested with my laptop, which does have NVIDIA ION, hardware acceleration works when camera is set to oblique by pressing F3, otherwise it's black unless zoomed in. This also proves that the problem lies in the z-buffering.
I am also running an Nvidia GPU (The 8800GTS) and also get the black screen issue when Hardware Acc is enabled.
I don't know if this is the same or a related issue to the black screen flickering etc, but as of right now the game refuses to load at all for me. I get it to start, but it then immediately goes into Not Responding, and I cannot move my mouse or anything to force close it.
Post edited August 26, 2011 by Forceflow15
http://forums.amd.com/game/messageview.cfm?catid=279&threadid=152754
Those screenshots looks kinda familiar, what you think? =)

Judging from that the fix has to be done by EA modifying the game's source code, and I don't think they will do that... And neither will ATI add the support for 16bit z-buffer again.
I can live without the hardware settings the game is awesome anyway and allways have been. but they could attleast try and make it so i can play in higher res than 800x600 without constant crashing.

in 800x600 it works fine though.
avatar
Deadrat: I can live without the hardware settings the game is awesome anyway and allways have been. but they could attleast try and make it so i can play in higher res than 800x600 without constant crashing.

in 800x600 it works fine though.
Yeah, but I want to play it with hardware mode enabled, as I used to 10 years ago... Software mode just looks bad.
avatar
Firek: We are currently gathering more information about the black screen glitch on ATI graphics cards. The game runs stable on all machines and all operating systems (Windows 7 included) when hardware acceleration is disabled and on 800x600 resolution - 1024x768 may be unstable on some machines.

Until we can come up with a permanent solution, ATI users should use this workaround. You need to extract it and launch the dk2_safemode.exe file from anywhere. It will also enable bilinear filtering and make software mode look a lot better.

Please send us a tech support ticket with a DXDiag.txt file if you're encountering this or any other issue, especially if you're getting the black screen glitch on NVidia graphics (still unconfirmed). It will help us investigate this issue further.

We sincerely apologize for the inconvenience and will keep you updated about our progress in this thread.
It'd be nice if EA released to source code, or at least made it available to CDProjekt so you can properly add 32bit Z-Buffering... And add widescreen support while you're at it!!!

:)
I'm not sure if this helps for windows 7 but I have made it playable on XP. I posted this on a youtube vid, link below, and will copy it here. Hope it helps out gog.com to maybe find a permanent solution.

"im not sure if its the same for 7, but i finally got the game to work WITHOUT CRASHING AT ALL....EVER!!!!

if you goto start ->run type "regedit"

then goto....

HKEYCURRENTUSER->Software->Bul­lfrog Productions Ltd->Dungeon Keeper II ->Configuration->Video->Engine­ID=2

so i just tried randomly to goto 2 and it worked! if it already says 2 maybe try 4..

the commentary sound is a little jumpy, but the actual gameplay sound/graphics are 100% good. and no crashing! enjoy!"


http://youtu.be/-yXnkCO3K9M


PLEASE gog fix these crashes so many of us will buy this game. They should be relatively basic to fix once found.
Thank you for this. I actually was able to play through a whole level without crashing. Having no voice acting is a bit disconcerting, but a small price to pay for actually having some stability.