It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
i downloaded the patch for dungeon keeper 2 (hardware acceleration fix) and i get black screen. nothing happens and i have to Ctrl Alt Delete to end it. I tried to run in safe mode and i don't get black screen but the menu buttons to play are invisible
No posts in this topic were marked as the solution yet. If you can help, add your reply
Hit Win+r to open the run dialog, Type '%APPDATA%/GOG/DungeonKeeper2/config.ini', (without the ') and underneath the LowZBuffer line, add 'Antialias=0'. (Again, without the ')

What graphics card do you have?
thank you that seemed to have fixed it and in regards of the graphics card im currently using an ATI radeon HD 6530 card.
avatar
PlanesWalker1337: thank you that seemed to have fixed it and in regards of the graphics card im currently using an ATI radeon HD 6530 card.
Another model without dedicated graphics ram. That seems to be what's causing it. :/

Thanks for reporting back, and glad it's working now. :)
For me, this is what solved the black screen issue in Dungeon Keeper 2 (ver 1.51).
OS: Windows Xp.

1. Click on the Start Menu in the lower left corner.
2. Pick "Run..." in the menu.
3. Type: dxdiag
4. Pick the "Display" tab at the top.
5. In the "DirectX Features" area click on "Disable" right next to "DirectDraw Acceleration".

After that, Dungeon Keeper 2 worked fine for me.