It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
When I first returned to this game, there was nothing I could do to get it to run for more than a few minutes before the game would crash. I'm running Win11 build 22557.1000. AMD 3900X, x570 Aorus Master. Moving from full screen to Windowed, and dropping the res to 2560 x 1440P, from 4k, helped some as it seemed to stay up longer without crashing. But it still crashed after a time. Nothing I did made the game stable--reducing texture res, resolution, moving to windowed from full screen, kept the game up longer--but it would still crash.

But I have solved the problem as last evening I played at the full 4k resolution, windowed, for two hours straight without a single crash! I think I've solved the problem, finally. And it revolves around something I'd forgotten to do when I updated the GOG version to 1.05A and decided to play again.

I had completely forgotten about the need to use the 4GB patch on older games that allows them to double the size of the virtual memory the game can use from 2GBs to 4GBs. Latest version:

https://ntcore.com/?page_id=371

Make sure to apply the patch to the correct file, Dragon Age Origins\bin_ship\DAorigins.exe

That is the game's main executable. 9978KB in size.

After I did that, the game, plus the mods I'm using began to run at 4k, full textures--I'm running JB's High-Res texture mod--and a few other mods--without a single crash for hours. I was quite surprised by the difference.

Also, for the DAOrigins.exe, I've set the properties\compatibility tab "Change settings for all users" the "run this program in Windows Vista Service pack 2" mode, run this program as an administrator, and "change high DPI settings" to "application" at the bottom of the tab--and you should then be good to go...;)

I'm skeptical about the fullscreen mode working as well as the Windowed--but I plan to experiment this evening and I will return with an update about that.

EDIT: Well, now the game is running perfectly in full screen mode under Win11--just got through playing for an hour and a half with not a single crash! Had to eat supper--heading back to the game right now, but wanted to add to this post. The game runs on my 50th Ann Ed 5700XT at 4k better than it ever ran when it was released. This is a really good game--very enjoyable--lots of content, fairly deep storyline--I think all of the succeeding DA games are lacking compared with it.

EDIT#2: On the configuration menu, under Video Options, the only things I would select are "Play in full screen" and "Disable intro movies." Leave the rest blank.
Post edited February 23, 2022 by waltc
Do you know if the toggle option run/walk is broken? Because the only thing that toggles is the selected character in third person view and with WASD. Otherwise, everyone is ALWAYS RUNNING, which makes the game unbearable to me.

I´ve tried everything and no way. Let´s put it clear. I want me and my party to WALK, in group, GROUP WALK. Can´t achieve this.

Only the slected character walks if toggled, with WASD, but party members STILL RUN, annoying, and even if toggled to walk, CLICK on anything interactable makes the character to RUN!!, i dont know if this is a glitch of this version of the game or whatever but it´s eliminatory for me, Uninstalled and deleted.

I need to know if people is just ok with this always sprint mode, because for me, considering how small the maps are, non-openworld, and the thight some closed areas may be, OMG. Even kotor had group walk solved easy.

Is there something in the tactics menu?
4gb patch worked for me!