It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So, I bought the complete package, installed all the 36GB of data, applied the patch to the latest version.
And now when I start the game up and take a look at the "Downloadable content" section I see nothing!
Basically I only can play the original game without any DLCs.

The DLCs are all installed in the correct subfolders of the game as far as I can tell. So this whole stuff is puzzling me quite a bit.

How can I enable the DLCs on my PC?
BTW it is a Win 7 machine that is (currently) not connected to the internet.

Any advice is appreciated.

This question / problem has been solved by Sarafanimage
Just run the game as administrator. Right click on the shortcut, choose Properties, go to the Compatibility tab and check the Run as administrator box. Now run the game from this shortcut. It should bring back the DLC.
Thanks Sarafran,

your tipp solved the issue.

Always these not good managed access rights on Windows.

This is NOT the whole story! Please see this post:

You need to copy the files AddIns.xml and offers.xml from the Documents\BioWare\Dragon Age\Settings folder of your administrator account to that of your normal user account. Then you should be able to run DAO and have both Awakening and all the DLC accessible without requiring elevated privileges.
To summarize, DA:O stores two files in your PERSONAL "Documents" folder that determine which DLC you have access to. The GOG installer will set these correctly only for the current user when installing or repairing the game. You can fix the problem simply by making sure those files are present in Documents\BioWare\Dragon Age\Settings for each user you want to be able to run the game.
Post edited November 25, 2018 by LoneIgadzra