It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

So... new playthrough, thought i'd use a custom undead character, try some new approaches (generally avoided magic and rogue builds on previous runs)..

Currently stuck at the 'Vision of the Hall of Echoes' sequence after the escape from the island.

Unable to bless any of the gods as the bless skill only blesses my character, and not the god(s) themselves. Can't progress the quest.

Have tried the shapeshift skill, makes no difference. Have tried changing the camera position (too long trying to get that elusive 'sweet spot' as per various suggestions on other forums).

Have gone back to a previous save out of curiosity, and it looks like the bless skill is borked as i can't bless anything other than myself, which makes one smaller quest uncompletable (the burning pigs) but also makes the main questline broken as well.

This is super frustrating. I've encountered problems with quests in other playthroughs, but nothing that i couldn't just ignore or work around.

Has anyone had any experience of this, any idea how to get round it without binning the playthrough completely and starting again (which i don't want to do, if it comes to that, i'll probably just uninstal as i really cbfa at this point)