It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi folks,
I recently purchased the Diablo + Hellfire game and have an issue.
This is the only game i have.
The game will not load into Full Screen, and i'm stuck playing in a little box. I have the full Screen Mode on in settings
and have made sure the Compatability to Disable full Screen is not marked.
Also, each game gets progressively smaller. Diablo is largest to Hellfire, which is tiny.
Anyone ? All help appreciated!


The game is the same size as when loaded on Windowed Setting, and is in the center of the
Edit 2
This game should go to Full Screen when the play button is pressed in the Galaxy Window, and not start as a Window.
It could be changed to a Window if someone wanted that mode. I feel ripped off.
Post edited August 30, 2020 by masscaster
No posts in this topic were marked as the solution yet. If you can help, add your reply
Have you solved your problem, I see that you've reached 10 hours of playing, or maybe trying to set up the game.

For me it worked fine, starting from galaxy or from the game folder it would go to full screen.
Hi Drazencrow,
It is still loading in the box. It loads in the box via Galaxy and from the game shortcut.

I've played some because that's what i bought it for, but it just sucks.

I have no idea how to fix it.

I've also checked my DirectX version and all is good.

On my side if Display mode is set to Same as desktop it will always go to the full screen.
Also check dxcfg.ini inside game subfolder (dx), maybe for some reason settings aren't saved, settings for those on the picture.

1.jpg (67 Kb)
Post edited August 31, 2020 by DrazenCro
Make sure that GPU scaling is enabled within your graphics driver control panel:

You'll want to ensure the scaling mode is set to "aspect ratio".