It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

benhun1: I've opened up ports 6112-6119, TCP & UDP on my Router.
I've opened up ports 6112-6119 TCP & UDP, plus 3724 TCP on my Firewall.
Still, nothing, Any help?
svfn: have you added Diablo.exe to allow on Public/Private networks in Windows Firewall?

there may be already an entry, but "Allow another app" anyway and browse to GOG folder's Diablo.exe
That did it, thank you so much!
St.Ross: Seems like the same issue has been addressed here.

I'd suggest contacting the official support since it's directly related to the functionality.
S1acker: Unite to destroy Diablo - up to 4 players can band together via Internet, or play head-to-head via direct IP. <-- This is what the description says about the game. I cannot seem to find any way to connect via direct IP nor can I play through as long as Blizzard don't fix this problem (which has been an issue for years). Please do what you can from your end to fix this!
For direct IP games I would suggest using DevilutionX:
Just to have out there. Try closing any other Blizzard games or launchers on your network.
My brother could not get into BNet because our Father had the Blizzard App open on his computer (the Blizz website mentions it using 6112).

Also, as svfn said. The easiest and surest method to get Diablo through your firewall is to add the Diablo.exe and ensure private is checked. Turning your firewall off doesn't always work. In my case it has never worked.

Along with that, make sure you have your network set to Private and NOT Public. When your network is set as Public your firewall uses an entirely different profile regarding inbound/outbound rules. This caused us issues when trying out LAN play.

Try checking if you have DMZ enabled on your outer. I have read routers check Port Forwards first, but DMZ has always jacked up my Port Forwards. If you don't know what DMZ is you most likely don't have it enabled, so no worries x)

Post edited March 23, 2019 by SpaceBass
Hi People.
I had the same problem - Diablo can chat but not play games.
I tried allowing Diablo through firewall - failed.
I found it's not Diablo you should care about - it's BNUpdate.exe.
Create an inbound rule for it and you're good to go.
Or at least it worked for me - maybe work for you too.
Good luck playing this wonderful classic !
I followed this guide and it worked for me: