It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
So when I meet Lorraine I am no longer actually able to play the game because I can't see what the replies are, or what she's saying (audio is fine though.)

Probably unrelated, but just in case, the icon seems to be messed up in the taskbar.

Tutorials aren't showing up in the menu, but I don't know if that's normal or not.
Attachments:
No posts in this topic were marked as the solution yet. If you can help, add your reply
I'm having the same problem. Also under options, I can't see any settings under Audio nor under Controls (I can only change input, not individual settings)

I'm running Linux Mint 18, which is based off Ubuntu 16.04
Post edited October 06, 2016 by somegamingdude
avatar
somegamingdude: I'm having the same problem. Also under options, I can't see any settings under Audio nor under Controls (I can only change input, not individual settings)

I'm running Linux Mint 18, which is based off Ubuntu 16.04
Good News! I got this fixed while trying to get Neoscavenger to work, so I don't know what did it for sure, so here's everything I did:

Uninstalled it

sudo update-pciids
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install

*lots of trying to get neoscavenger to run through the terminal so I could track down errors*

sudo apt-get install libnss3:i386
sudo apt-get install ia32-libs-gtk
sudo apt-get flashplugin-installer:i386

(That last one probably didn't do anything)

*more attempts to get scavenger to work*

sudo apt-get install curl:i386

*get bored and goes to poke at dex again, reinstalling it and...what, I can see?!*

it's not perfect in the shops but it's working
Sigh unfortunately it didn't work for me.

I was able to do everything per your instructions except: sudo apt-get flashplugin-installer i:386

Which returns an error of: Invalid Operation

Trying: sudo apt-get install flashplugin-installer:i386

Returns that there are missing dependencies but they're not installable

Depends: update-notifier-common:i386 (>= 0.119ubuntu2) but it is not installable
E: Unable to correct problems, you have held broken packages.


But I do agree with you; its unlikely that Dex will rely on this package.

So unfortunately a no go for me. But I do appreciate your help, thank you :).
avatar
somegamingdude: But I do agree with you; its unlikely that Dex will rely on this package.
Did you check the game page?
Requires the following packages to be installed: libc6:i386 libasound2:i386 libasound2-data:i386 libasound2-plugins:i386 libstdc++6:i386 libx11-6:i386 libxau6:i386 libxcb1:i386 libxcursor1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxinerama1:i386 libxrandr2:i386 libxrender1:i386 libglu1:i386
Not sure if that's been updated for 16.04/Mint 18.
Yup all those packages were already installed due to other GOG games requiring them.

Unfortunately it seems that this is a documented issue and the developers have yet to take action on it.

This is rather disappointing...I would hope that GOG takes a stronger stance on this stuff and not accept or sell broken software.

Note: So it turns out I can't post any links at this time (maybe I haven't posted enough), but if you were to look up steam , dex no text in dialogue, you'd probably find the link I'm looking for. The developers themselves comment in this thread which is inow 6 months old.
avatar
NemiThine: So when I meet Lorraine I am no longer actually able to play the game because I can't see what the replies are, or what she's saying (audio is fine though.)

Probably unrelated, but just in case, the icon seems to be messed up in the taskbar.

Tutorials aren't showing up in the menu, but I don't know if that's normal or not.
Can you check if version 5.3.0.0 fixes these issues for you?
avatar
NemiThine: So when I meet Lorraine I am no longer actually able to play the game because I can't see what the replies are, or what she's saying (audio is fine though.)

Probably unrelated, but just in case, the icon seems to be messed up in the taskbar.

Tutorials aren't showing up in the menu, but I don't know if that's normal or not.
avatar
JudasIscariot: Can you check if version 5.3.0.0 fixes these issues for you?
Sure did! a little weird in some places, but I don't notices mostly.
Hello,
I have exactly the same issue on Linux Mint 18: no dialog text displayed, what makes it unplayable really.

Some info:

~/GOG Games/Dex $ cat gameinfo
Dex
2.2.0.3
5.3.0.0

~/GOG Games/Dex $ uname -a
Linux blabla 4.4.0-47-generic #68-Ubuntu SMP Wed Oct 26 19:39:52 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

~/GOG Games/Dex $ cat /etc/lsb-release
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=18
DISTRIB_CODENAME=sarah
DISTRIB_DESCRIPTION="Linux Mint 18 Sarah"

~/GOG Games/Dex $ lspci
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:16.3 Serial controller: Intel Corporation 8 Series/C220 Series Chipset Family KT Controller (rev 04)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-LM (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d4)
00:1c.2 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #3 (rev d4)
00:1c.4 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #5 (rev d4)
00:1c.5 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #6 (rev d4)
00:1c.6 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #7 (rev d4)
00:1c.7 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #8 (rev d4)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM87 Express LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars XTX [Radeon HD 8790M] (rev ff)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)
0e:00.0 SD Host controller: O2 Micro, Inc. SD/MMC Card Reader Controller (rev 01)
Attachments:
Post edited November 24, 2016 by sleeperor
I've got the same issue on my laptop running Mint 18.
Dex is latest version.

Some info about my laptop:
Intel 3rd Gen Core processor Graphics Controller
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.02hz
GLX Renderer: Mesa DRI Intel Ivybridge Mobile
GLX Version: 3.0 Mesa 11.2.0



Interestingly dialog text showed up after I switched the font size to normal (from large).
Still no entries in the audio menu, though.
I had the same problem. Also on Mint 18. Changed the dialogue font size to small in the settings and they started showing up. Give it a shot and see if it helps anyone else.


Edit: Oh, and for the Audio menu, try leaving a terminal window open on your desktop before you launch the game. This also helps with a lot of the CTD / Cinnamon crashing in launch problems with games.... no idea why, but it helps.
Post edited November 25, 2016 by xiahou
OK, so I tried every possible font size and still nothing.
The menus started working today for me.
Dialogues are still not 100% right though, e.g. scrolling does not work right - the text moves up and down, but is not limited to the dialogue boxes.

Not sure why it behaves that way - game seems a bit hit or miss there.

Guess it might help to change the font size and then restart the game a couple times until it works.
Post edited November 26, 2016 by ElZoido
Have the same problem on Elementary OS 0.4, based Ubuntu 16.04 x64. Dialogs and part of menus with invisible text...
Don't know what to do.
Attachments:
dex-1.png (413 Kb)
dex-2.png (493 Kb)
I just pressed "Back to defaults" in video settings and text became visible!